# CVE-2025-64170: sudo-rs: Partial password reveal is possible after timeout

> An attacker can view partial passwords on the console if a user times out during entry, potentially aiding social engineering or shoulder-surfing attacks.

- **Severity:** Low 3.8 (`CVSS:3.1/AV:P/AC:H/PR:H/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Nov 2025
- **Updated:** 14 Nov 2025
- **Also known as:** DEBIAN-CVE-2025-64170, GHSA-c978-wq47-pvvw, MINI-mxw6-8xjg-www7, UBUNTU-CVE-2025-64170

## What is CVE-2025-64170?

CVE-2025-64170 is a low-severity vulnerability in trifectatechfoundation sudo-rs, published on 12 Nov 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

sudo-rs is a memory safe implementation of sudo and su written in Rust. Starting in version 0.2.7 and prior to version 0.2.10, if a user begins entering a password but does not press return for an extended period, a password timeout may occur. When this happens, the keystrokes that were entered are echoed back to the console. This could reveal partial password information, possibly exposing history files when not carefully handled by the user and on screen, usable for Social Engineering or Pass-By attacks. Version 0.2.10 fixes the issue.

Weakness: CWE-549 (Missing Password Field Masking)

## Which versions are affected by CVE-2025-64170?

2 open source packages ship an affected version, including sudo-rs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sudo-rs` | crates.io | From 0.2.7 | 0.2.10 |
| `sudo-rs` | crates.io | From 0.2.7 | 0.2.10 |

## How do I fix CVE-2025-64170?

Upgrade sudo-rs to 0.2.10 or later.

## Is CVE-2025-64170 being exploited?

There is no known exploitation of CVE-2025-64170 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64170 and fix it if it is affected.

What it is: CVE-2025-64170 is a low-severity vulnerability in trifectatechfoundation sudo-rs, published on 12 Nov 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-64170 in the wild and no public exploit code.

Affected packages and fixed versions:
- sudo-rs (crates.io): affected from 0.2.7; fixed in 0.2.10
- sudo-rs (crates.io): affected from 0.2.7; fixed in 0.2.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64170/ (Markdown: https://insights.sbomify.com/CVE-2025-64170/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64170
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64170
- OSV: https://osv.dev/vulnerability/CVE-2025-64170

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64170/
Summaries are generated and may contain mistakes; the official description above is the record.
