CVE-2025-64173 Apollo Router Core: Access Control Bypass on Polymorphic Types
Unauthenticated attackers can access restricted data by exploiting incorrect access control handling on polymorphic types in Apollo Router Core.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-64173?
CVE-2025-64173 is a high-severity authentication bypass vulnerability in apollographql router, published on 6 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apollo Router Core is a configurable graph router written in Rust to run a federated supergraph using Apollo Federation 2. In versions 1.61.11 below, as well as 2.0.0-alpha.0 through 2.8.1-rc.0, a vulnerability allowed for unauthenticated queries to access data that required additional access controls. Router incorrectly handled access control directives on interface types/fields and their implementing object types/fields, applying them to interface types/fields while ignoring directives on their implementing object types/fields when all implementations had the same requirements. Apollo Router customers defining @authenticated, @requiresScopes, or @policy directives inconsistently on polymorphic types (i.e., object types that implement interface types) are impacted. This issue is fixed in versions 1.61.12 and 2.8.1.
Weakness: CWE-288
Which versions are affected by CVE-2025-64173?
4 open source packages ship an affected version, including apollo-router.
| Package | Affected | Fixed in |
|---|---|---|
apollo-router crates.io | All versions | 1.61.12 |
apollo-router crates.io | All versions | 1.61.12 |
apollo-router crates.io | From 2.0.0-alpha.0 | 2.8.1 |
apollo-router crates.io | From 2.0.0-alpha.0 | 2.8.1 |
How do I fix CVE-2025-64173?
Upgrade apollo-router to a fixed version for your release line: 1.61.12 or 2.8.1.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-64173 being exploited?
There is no known exploitation of CVE-2025-64173 in the wild and no public exploit code.
Sources
Also known as GHSA-x33c-7c2v-mrj9.