{"answers":{"affected":"4 open source packages ship an affected version, including apollo-router.","exploited":"There is no known exploitation of CVE-2025-64173 in the wild and no public exploit code.","fix":"Upgrade apollo-router to a fixed version for your release line: 1.61.12 or 2.8.1.","what":"CVE-2025-64173 is a high-severity authentication bypass vulnerability in apollographql router, published on 6 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-64173 and fix it if it is affected.\n\nWhat it is: CVE-2025-64173 is a high-severity authentication bypass vulnerability in apollographql router, published on 6 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-64173 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apollo-router (crates.io): affected all versions; fixed in 1.61.12\n- apollo-router (crates.io): affected all versions; fixed in 1.61.12\n- apollo-router (crates.io): affected from 2.0.0-alpha.0; fixed in 2.8.1\n- apollo-router (crates.io): affected from 2.0.0-alpha.0; fixed in 2.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64173/ (Markdown: https://insights.sbomify.com/CVE-2025-64173/index.md)","id":"CVE-2025-64173","markdown":"https://insights.sbomify.com/CVE-2025-64173/index.md","name":"CVE-2025-64173","record":{"aliases":["GHSA-x33c-7c2v-mrj9"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Apollo Router Core","requires_auth":"none","summary":"Unauthenticated attackers can access restricted data by exploiting incorrect access control handling on polymorphic types in Apollo Router Core.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-288","name":"Authentication Bypass Using an Alternate Path or Channel"}],"description":"Apollo Router Core is a configurable graph router written in Rust to run a federated supergraph using Apollo Federation 2. In versions 1.61.11 below, as well as 2.0.0-alpha.0 through 2.8.1-rc.0, a vulnerability allowed for unauthenticated queries to access data that required additional access controls. Router incorrectly handled access control directives on interface types/fields and their implementing object types/fields, applying them to interface types/fields while ignoring directives on their implementing object types/fields when all implementations had the same requirements. Apollo Router customers defining @authenticated, @requiresScopes, or @policy directives inconsistently on polymorphic types (i.e., object types that implement interface types) are impacted. This issue is fixed in versions 1.61.12 and 2.8.1.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apollo Router Core: Access Control Bypass on Polymorphic Types","id":"CVE-2025-64173","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":4,"n_references":3,"next":{"headline":"OpenMage is vulnerable to XSS in Admin Notifications","id":"CVE-2025-64174"},"packages":[{"ecosystem":"crates.io","fixed":["1.61.12"],"introduced":["0"],"last_affected":[],"package":"apollo-router","purl":null,"source":"GHSA-x33c-7c2v-mrj9"},{"ecosystem":"crates.io","fixed":["1.61.12"],"introduced":["0"],"last_affected":[],"package":"apollo-router","purl":"pkg:cargo/apollo-router","source":"GHSA-x33c-7c2v-mrj9"},{"ecosystem":"crates.io","fixed":["2.8.1"],"introduced":["2.0.0-alpha.0"],"last_affected":[],"package":"apollo-router","purl":null,"source":"GHSA-x33c-7c2v-mrj9"},{"ecosystem":"crates.io","fixed":["2.8.1"],"introduced":["2.0.0-alpha.0"],"last_affected":[],"package":"apollo-router","purl":"pkg:cargo/apollo-router","source":"GHSA-x33c-7c2v-mrj9"}],"prev":{"headline":"MARIN3R: Cross-Namespace Vulnerability in the Operator","id":"CVE-2025-64171"},"products":["router"],"published":"2025-11-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-07","vendors":["apollographql"]},"summary":"Unauthenticated attackers can access restricted data by exploiting incorrect access control handling on polymorphic types in Apollo Router Core.","url":"https://insights.sbomify.com/CVE-2025-64173/"}