# CVE-2025-64173: Apollo Router Core: Access Control Bypass on Polymorphic Types

> Unauthenticated attackers can access restricted data by exploiting incorrect access control handling on polymorphic types in Apollo Router Core.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Nov 2025
- **Updated:** 7 Nov 2025
- **Also known as:** GHSA-x33c-7c2v-mrj9

## What is CVE-2025-64173?

CVE-2025-64173 is a high-severity authentication bypass vulnerability in apollographql router, published on 6 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apollo Router Core is a configurable graph router written in Rust to run a federated supergraph using Apollo Federation 2. In versions 1.61.11 below, as well as 2.0.0-alpha.0 through 2.8.1-rc.0, a vulnerability allowed for unauthenticated queries to access data that required additional access controls. Router incorrectly handled access control directives on interface types/fields and their implementing object types/fields, applying them to interface types/fields while ignoring directives on their implementing object types/fields when all implementations had the same requirements. Apollo Router customers defining @authenticated, @requiresScopes, or @policy directives inconsistently on polymorphic types (i.e., object types that implement interface types) are impacted. This issue is fixed in versions 1.61.12 and 2.8.1.

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2025-64173?

4 open source packages ship an affected version, including apollo-router.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apollo-router` | crates.io | All versions | 1.61.12 |
| `apollo-router` | crates.io | All versions | 1.61.12 |
| `apollo-router` | crates.io | From 2.0.0-alpha.0 | 2.8.1 |
| `apollo-router` | crates.io | From 2.0.0-alpha.0 | 2.8.1 |

## How do I fix CVE-2025-64173?

Upgrade apollo-router to a fixed version for your release line: 1.61.12 or 2.8.1.

## Is CVE-2025-64173 being exploited?

There is no known exploitation of CVE-2025-64173 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64173 and fix it if it is affected.

What it is: CVE-2025-64173 is a high-severity authentication bypass vulnerability in apollographql router, published on 6 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64173 in the wild and no public exploit code.

Affected packages and fixed versions:
- apollo-router (crates.io): affected all versions; fixed in 1.61.12
- apollo-router (crates.io): affected all versions; fixed in 1.61.12
- apollo-router (crates.io): affected from 2.0.0-alpha.0; fixed in 2.8.1
- apollo-router (crates.io): affected from 2.0.0-alpha.0; fixed in 2.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64173/ (Markdown: https://insights.sbomify.com/CVE-2025-64173/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64173
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64173
- OSV: https://osv.dev/vulnerability/CVE-2025-64173

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64173/
Summaries are generated and may contain mistakes; the official description above is the record.
