{"answers":{"affected":"2 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64174 exists.","fix":"Upgrade openmage/magento-lts to 20.16.0 or later.","what":"CVE-2025-64174 is a medium-severity cross-site scripting vulnerability in OpenMage magento-lts, published on 6 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-64174 and fix it if it is affected.\n\nWhat it is: CVE-2025-64174 is a medium-severity cross-site scripting vulnerability in OpenMage magento-lts, published on 6 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64174 exists.\n\nAffected packages and fixed versions:\n- openmage/magento-lts (Packagist): affected all versions; fixed in 20.16.0\n- openmage/magento-lts (Packagist): affected all versions; fixed in 20.16.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64174/ (Markdown: https://insights.sbomify.com/CVE-2025-64174/index.md)","id":"CVE-2025-64174","markdown":"https://insights.sbomify.com/CVE-2025-64174/index.md","name":"CVE-2025-64174","record":{"aliases":["GHSA-qv78-c8hc-438r"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Magento LTS","requires_auth":"high_privilege","summary":"An admin with database access or control over notification feeds can inject malicious scripts via unescaped translation strings, leading to potential account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"magento","vendor":"openmage"}],"cvss":{"score":4.6,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Magento-lts is a long-term support alternative to Magento Community Edition (CE). Versions 20.15.0 and below are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an admin with direct database access or the admin notification feed source to inject malicious scripts into vulnerable fields. Unescaped translation strings and URLs are printed into contexts inside app/code/core/Mage/Adminhtml/Block/Notification/Grid/Renderer/Actions.php. A malicious translation or polluted data can inject script. This issue is fixed in version 20.16.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"OpenMage is vulnerable to XSS in Admin Notifications","id":"CVE-2025-64174","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Gogs Vulnerable to 2FA Bypass via Recovery Code","id":"CVE-2025-64175"},"packages":[{"ecosystem":"Packagist","fixed":["20.16.0"],"introduced":["0"],"last_affected":[],"package":"openmage/magento-lts","purl":null,"source":"GHSA-qv78-c8hc-438r"},{"ecosystem":"Packagist","fixed":["20.16.0"],"introduced":["0"],"last_affected":[],"package":"openmage/magento-lts","purl":"pkg:composer/openmage/magento-lts","source":"GHSA-qv78-c8hc-438r"}],"prev":{"headline":"Apollo Router Core: Access Control Bypass on Polymorphic Types","id":"CVE-2025-64173"},"products":["magento-lts"],"published":"2025-11-06","related":[{"cvss_score":9.8,"headline":"Fixes a bug in Zend Framework's Stream HTTP Wrapper","id":"CVE-2021-21426","kev_date_added":null,"published":"2021-04-21"},{"cvss_score":9.1,"headline":"Backport for CVE-2021-21024 Blind SQLi from Magento 2","id":"CVE-2021-21427","kev_date_added":null,"published":"2021-04-21"},{"cvss_score":8.8,"headline":"OpenMage LTS authenticated remote code execution through layout update","id":"CVE-2021-41144","kev_date_added":null,"published":"2023-01-27"},{"cvss_score":8.7,"headline":"OpenMage LTS has Customer File Upload Extension Blocklist Bypass that Leads to Remote Code Execution","id":"CVE-2026-40488","kev_date_added":null,"published":"2026-04-20"},{"cvss_score":8.1,"headline":"OpenMage LTS's Phar Deserialization leads to Remote Code Execution","id":"CVE-2026-25524","kev_date_added":null,"published":"2026-04-20"},{"cvss_score":8,"headline":"RCE in Magento","id":"CVE-2020-15244","kev_date_added":null,"published":"2020-10-21"},{"cvss_score":7.5,"headline":"Magento LTS's guest order \"protect code\" can be brute-forced too easily","id":"CVE-2023-41879","kev_date_added":null,"published":"2023-09-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-06","vendors":["OpenMage"]},"summary":"An admin with database access or control over notification feeds can inject malicious scripts via unescaped translation strings, leading to potential account takeover.","url":"https://insights.sbomify.com/CVE-2025-64174/"}