# CVE-2025-64174: OpenMage is vulnerable to XSS in Admin Notifications

> An admin with database access or control over notification feeds can inject malicious scripts via unescaped translation strings, leading to potential account takeover.

- **Severity:** Medium 4.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Nov 2025
- **Updated:** 6 Nov 2025
- **Also known as:** GHSA-qv78-c8hc-438r

## What is CVE-2025-64174?

CVE-2025-64174 is a medium-severity cross-site scripting vulnerability in OpenMage magento-lts, published on 6 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Magento-lts is a long-term support alternative to Magento Community Edition (CE). Versions 20.15.0 and below are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an admin with direct database access or the admin notification feed source to inject malicious scripts into vulnerable fields. Unescaped translation strings and URLs are printed into contexts inside app/code/core/Mage/Adminhtml/Block/Notification/Grid/Renderer/Actions.php. A malicious translation or polluted data can inject script. This issue is fixed in version 20.16.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-64174?

2 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openmage/magento-lts` | Packagist | All versions | 20.16.0 |
| `openmage/magento-lts` | Packagist | All versions | 20.16.0 |

Products: Openmage Magento.

## How do I fix CVE-2025-64174?

Upgrade openmage/magento-lts to 20.16.0 or later.

## Is CVE-2025-64174 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64174 exists.

## Other vulnerabilities in OpenMage magento-lts

- [CVE-2021-21426](https://insights.sbomify.com/CVE-2021-21426/): Fixes a bug in Zend Framework's Stream HTTP Wrapper (critical 9.8)
- [CVE-2021-21427](https://insights.sbomify.com/CVE-2021-21427/): Backport for CVE-2021-21024 Blind SQLi from Magento 2 (critical 9.1)
- [CVE-2021-41144](https://insights.sbomify.com/CVE-2021-41144/): OpenMage LTS authenticated remote code execution through layout update (high 8.8)
- [CVE-2026-40488](https://insights.sbomify.com/CVE-2026-40488/): OpenMage LTS has Customer File Upload Extension Blocklist Bypass that Leads to Remote Code Execution (high 8.7)
- [CVE-2026-25524](https://insights.sbomify.com/CVE-2026-25524/): OpenMage LTS's Phar Deserialization leads to Remote Code Execution (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64174 and fix it if it is affected.

What it is: CVE-2025-64174 is a medium-severity cross-site scripting vulnerability in OpenMage magento-lts, published on 6 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64174 exists.

Affected packages and fixed versions:
- openmage/magento-lts (Packagist): affected all versions; fixed in 20.16.0
- openmage/magento-lts (Packagist): affected all versions; fixed in 20.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64174/ (Markdown: https://insights.sbomify.com/CVE-2025-64174/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64174
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64174
- OSV: https://osv.dev/vulnerability/CVE-2025-64174

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64174/
Summaries are generated and may contain mistakes; the official description above is the record.
