CVE-2025-64175 Gogs Vulnerable to 2FA Bypass via Recovery Code
Attackers can bypass two-factor authentication using any unused recovery code, leading to full account takeover in Gogs.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-64175?
CVE-2025-64175 is a high-severity authentication bypass vulnerability in gogs, published on 6 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, Gogs’ 2FA recovery code validation does not scope codes by user, enabling cross-account bypass. If an attacker knows a victim’s username and password, they can use any unused recovery code (e.g., from their own account) to bypass the victim’s 2FA. This enables full account takeover and renders 2FA ineffective in all environments where it's enabled.. This issue has been patched in versions 0.13.4 and 0.14.0+dev.
Weakness: CWE-287
Which versions are affected by CVE-2025-64175?
3 open source packages ship an affected version, including gogs.io/gogs. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gogs.io/gogs Go | From 0.11.19 | None |
gogs.io/gogs Go | From 0.11.19 | 0.13.4 |
gogs.io/gogs Go | From 0.11.19 | 0.13.4 |
Products include Gogs Gogs.
How do I fix CVE-2025-64175?
Upgrade gogs.io/gogs to 0.13.4 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-64175 being exploited?
There is no known exploitation of CVE-2025-64175 in the wild and no public exploit code.
Other vulnerabilities in gogs
Sources
Also known as GHSA-p6x6-9mx6-26wj, GO-2026-4449.