# CVE-2025-64175: Gogs Vulnerable to 2FA Bypass via Recovery Code

> Attackers can bypass two-factor authentication using any unused recovery code, leading to full account takeover in Gogs.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-p6x6-9mx6-26wj, GO-2026-4449

## What is CVE-2025-64175?

CVE-2025-64175 is a high-severity authentication bypass vulnerability in gogs, published on 6 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, Gogs’ 2FA recovery code validation does not scope codes by user, enabling cross-account bypass. If an attacker knows a victim’s username and password, they can use any unused recovery code (e.g., from their own account) to bypass the victim’s 2FA. This enables full account takeover and renders 2FA ineffective in all environments where it's enabled.. This issue has been patched in versions 0.13.4 and 0.14.0+dev.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-64175?

3 open source packages ship an affected version, including gogs.io/gogs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogs.io/gogs` | Go | From 0.11.19 | None |
| `gogs.io/gogs` | Go | From 0.11.19 | 0.13.4 |
| `gogs.io/gogs` | Go | From 0.11.19 | 0.13.4 |

Products: Gogs Gogs.

## How do I fix CVE-2025-64175?

Upgrade gogs.io/gogs to 0.13.4 or later.

## Is CVE-2025-64175 being exploited?

There is no known exploitation of CVE-2025-64175 in the wild and no public exploit code.

## Other vulnerabilities in gogs

- [CVE-2025-8110](https://insights.sbomify.com/CVE-2025-8110/): Gogs Path Traversal (high 8.7, exploited in the wild)
- [CVE-2024-56731](https://insights.sbomify.com/CVE-2024-56731/): Gogs deletion of internal files allows remote command execution (critical 10.0)
- [CVE-2022-1884](https://insights.sbomify.com/CVE-2022-1884/): Remote Command Execution in gogs/gogs (critical 10.0)
- [CVE-2022-1986](https://insights.sbomify.com/CVE-2022-1986/): OS Command Injection in gogs/gogs (critical 10.0)
- [CVE-2022-1992](https://insights.sbomify.com/CVE-2022-1992/): Path Traversal in gogs/gogs (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64175 and fix it if it is affected.

What it is: CVE-2025-64175 is a high-severity authentication bypass vulnerability in gogs, published on 6 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64175 in the wild and no public exploit code.

Affected packages and fixed versions:
- gogs.io/gogs (Go): affected from 0.11.19; no fix listed
- gogs.io/gogs (Go): affected from 0.11.19; fixed in 0.13.4
- gogs.io/gogs (Go): affected from 0.11.19; fixed in 0.13.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64175/ (Markdown: https://insights.sbomify.com/CVE-2025-64175/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64175
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64175
- OSV: https://osv.dev/vulnerability/CVE-2025-64175

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64175/
Summaries are generated and may contain mistakes; the official description above is the record.
