# CVE-2025-64178: Jellysweep uses uncontrolled data in image cache API endpoint

> Authenticated attackers can exploit an unvalidated URL parameter in the image cache API to force the server to download arbitrary content, potentially accessing internal resources.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Nov 2025
- **Updated:** 7 Nov 2025
- **Also known as:** GHSA-xc93-q32j-cpcg, GO-2025-4091

## What is CVE-2025-64178?

CVE-2025-64178 is a high-severity server-side request forgery vulnerability in jon4hz jellysweep, published on 6 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jellysweep is a cleanup tool for the Jellyfin media server. In versions 0.12.1 and below, /api/images/cache, used to download media posters from the server, accepted a URL parameter that was directly passed to the cache package, which downloaded the poster from this URL. This URL parameter can be used to make the Jellysweep server download arbitrary content. The API endpoint can only be used by authenticated users. This issue is fixed in version 0.13.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-64178?

3 open source packages ship an affected version, including github.com/jon4hz/jellysweep.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/jon4hz/jellysweep` | Go | All versions | 0.13.0 |
| `github.com/jon4hz/jellysweep` | Go | All versions | 0.13.0 |
| `github.com/jon4hz/jellysweep` | Go | All versions | 0.13.0 |

## How do I fix CVE-2025-64178?

Upgrade github.com/jon4hz/jellysweep to 0.13.0 or later.

## Is CVE-2025-64178 being exploited?

There is no known exploitation of CVE-2025-64178 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64178 and fix it if it is affected.

What it is: CVE-2025-64178 is a high-severity server-side request forgery vulnerability in jon4hz jellysweep, published on 6 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64178 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/jon4hz/jellysweep (Go): affected all versions; fixed in 0.13.0
- github.com/jon4hz/jellysweep (Go): affected all versions; fixed in 0.13.0
- github.com/jon4hz/jellysweep (Go): affected all versions; fixed in 0.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64178/ (Markdown: https://insights.sbomify.com/CVE-2025-64178/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64178
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64178
- OSV: https://osv.dev/vulnerability/CVE-2025-64178

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64178/
Summaries are generated and may contain mistakes; the official description above is the record.
