# CVE-2025-64181: OpenEXR Makes Use of Uninitialized Memory

> An attacker can cause a denial of service or undefined behavior in applications using OpenEXR by triggering the use of uninitialized memory during file parsing.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2025
- **Updated:** 12 Nov 2025
- **Also known as:** DEBIAN-CVE-2025-64181, ECHO-90ed-3db2-7e6c, GHSA-3h9h-qfvw-98hq, OESA-2025-2710, OESA-2025-2711, OESA-2025-2712, OESA-2025-2713, OESA-2025-2740, PYSEC-2026-2843, ROOT-OS-DEBIAN-12-CVE-2025-64181, ROOT-OS-DEBIAN-13-CVE-2025-64181, SUSE-SU-2025:21014-1, openSUSE-SU-2025:20056-1

## What is CVE-2025-64181?

CVE-2025-64181 is a low-severity vulnerability in Openexr Openexr, published on 10 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. In versions 3.3.0 through 3.3.5 and 3.4.0 through 3.4.2, while fuzzing `openexr_exrcheck_fuzzer`, Valgrind reports a conditional branch depending on uninitialized data inside `generic_unpack`. This indicates a use of uninitialized memory. The issue can result in undefined behavior and/or a potential crash/denial of service. Versions 3.3.6 and 3.4.3 fix the issue.

Weakness: CWE-457 (Use of Uninitialized Variable)

## Which versions are affected by CVE-2025-64181?

5 open source packages ship an affected version, including openexr and OpenEXR. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openexr` | PyPI | From 3.3.0 | 3.3.6, 3.4.3 |
| `openexr` | PyPI | From 3.3.0 | 3.3.6 |
| `openexr` | PyPI | From 3.4.0 | 3.4.3 |
| `OpenEXR` | PyPI | From 3.3.0 | 3.3.6 |
| `OpenEXR` | PyPI | From 3.4.0 | 3.4.3 |
| `openexr` | SUSE:Linux Enterprise Server 16.0 | All versions | 3.2.2-160000.3.1 |
| `openexr` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 3.2.2-160000.3.1 |
| `openexr` | openSUSE:Leap 16.0 | All versions | 3.2.2-160000.3.1 |

Products: Openexr Openexr.

## How do I fix CVE-2025-64181?

Upgrade openexr to a fixed version for your release line: 3.3.6 or 3.4.3.

## Is CVE-2025-64181 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64181 exists.

## Other vulnerabilities in Openexr Openexr

- [CVE-2023-5841](https://insights.sbomify.com/CVE-2023-5841/): OpenEXR Heap Overflow in Scanline Deep Data Parsing (critical 9.1)
- [CVE-2026-41142](https://insights.sbomify.com/CVE-2026-41142/): OpenEXR is Vulnerable to Integer overflow in ImageChannel::resize leads to heap OOB write via OpenEXRUtil public API (high 8.8)
- [CVE-2026-42216](https://insights.sbomify.com/CVE-2026-42216/): OpenEXR: Out-of-bounds read in `IDManifest::init()` during prefix expansion (high 8.8)
- [CVE-2017-9111](https://insights.sbomify.com/CVE-2017-9111/): OpenEXR invalid write (high 8.8)
- [CVE-2017-9113](https://insights.sbomify.com/CVE-2017-9113/): Memory corruption in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64181 and fix it if it is affected.

What it is: CVE-2025-64181 is a low-severity vulnerability in Openexr Openexr, published on 10 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64181 exists.

Affected packages and fixed versions:
- openexr (PyPI): affected from 3.3.0; fixed in 3.3.6, 3.4.3
- openexr (PyPI): affected from 3.3.0; fixed in 3.3.6
- openexr (PyPI): affected from 3.4.0; fixed in 3.4.3
- OpenEXR (PyPI): affected from 3.3.0; fixed in 3.3.6
- OpenEXR (PyPI): affected from 3.4.0; fixed in 3.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64181/ (Markdown: https://insights.sbomify.com/CVE-2025-64181/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64181
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64181
- OSV: https://osv.dev/vulnerability/CVE-2025-64181

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64181/
Summaries are generated and may contain mistakes; the official description above is the record.
