CVE-2025-64182 OpenEXR has buffer overflow in PyOpenEXR_old's channels() and channel()
Integer overflow in OpenEXR Python adapter allows heap overflow or null dereference, enabling code execution or crashes via crafted EXR files.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-64182?
CVE-2025-64182 is a medium-severity vulnerability in Openexr Openexr, published on 10 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. In versions 3.2.0 through 3.2.4, 3.3.0 through 3.3.5, and 3.4.0 through 3.4.2, a memory safety bug in the legacy OpenEXR Python adapter (the deprecated OpenEXR.InputFile wrapper) allow crashes and likely code execution when opening attacker-controlled EXR files or when passing crafted Python objects. Integer overflow and unchecked allocation in InputFile.channel() and InputFile.channels() can lead to heap overflow (32 bit) or a NULL deref (64 bit). Versions 3.2.5, 3.3.6, and 3.4.3 contain a patch for the issue.
Weakness: CWE-120
Which versions are affected by CVE-2025-64182?
7 open source packages ship an affected version, including openexr and OpenEXR. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openexr PyPI | From 3.2.0 | 3.2.5, 3.3.6, 3.4.3 |
openexr PyPI | From 3.2.0 | 3.2.5 |
openexr PyPI | From 3.3.0 | 3.3.6 |
openexr PyPI | From 3.4.0 | 3.4.3 |
OpenEXR PyPI | From 3.2.0 | 3.2.5 |
OpenEXR PyPI | From 3.3.0 | 3.3.6 |
1 more packages
OpenEXR PyPI | From 3.4.0 | 3.4.3 |
Products include Openexr Openexr.
How do I fix CVE-2025-64182?
Upgrade openexr to a fixed version for your release line: 3.2.5, 3.3.6 or 3.4.3.
Is CVE-2025-64182 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64182 exists.
Other vulnerabilities in Openexr Openexr
- CVE-2023-5841 OpenEXR Heap Overflow in Scanline Deep Data Parsing
- CVE-2026-41142 OpenEXR is Vulnerable to Integer overflow in ImageChannel::resize leads to heap OOB write via OpenEXRUtil public API
- CVE-2026-42216 OpenEXR: Out-of-bounds read in `IDManifest::init()` during prefix expansion
- CVE-2017-9111 OpenEXR invalid write
- CVE-2017-9113 Memory corruption in n/a
Sources
Also known as GHSA-vh63-9mqx-wmjr, JLSEC-2026-138, PYSEC-2026-2851.