# CVE-2025-64183: OpenEXR has use after free in PyObject_StealAttrString

> A use-after-free vulnerability in OpenEXR's Python bindings allows attackers to execute arbitrary code or cause denial of service via crafted EXR files.

- **Severity:** Medium 5.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2025
- **Updated:** 14 Nov 2025
- **Also known as:** GHSA-57cw-j6vp-2p9m, JLSEC-2026-139, PYSEC-2026-2844

## What is CVE-2025-64183?

CVE-2025-64183 is a medium-severity use after free vulnerability in Openexr Openexr, published on 10 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. In versions 3.2.0 through 3.2.4, 3.3.0 through 3.3.5, and 3.4.0 through 3.4.2, there is a use-after-free in PyObject_StealAttrString of pyOpenEXR_old.cpp. The legacy adapter defines PyObject_StealAttrString that calls PyObject_GetAttrString to obtain a new reference, immediately decrefs it, and returns the pointer. Callers then pass this dangling pointer to APIs like PyLong_AsLong/PyFloat_AsDouble, resulting in a use-after-free. This is invoked in multiple places (e.g., reading PixelType.v, Box2i, V2f, etc.) Versions 3.2.5, 3.3.6, and 3.4.3 fix the issue.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2025-64183?

7 open source packages ship an affected version, including openexr and OpenEXR. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openexr` | PyPI | From 3.2.0 | 3.2.5, 3.3.6, 3.4.3 |
| `openexr` | PyPI | From 3.2.0 | 3.2.5 |
| `openexr` | PyPI | From 3.3.0 | 3.3.6 |
| `openexr` | PyPI | From 3.4.0 | 3.4.3 |
| `OpenEXR` | PyPI | From 3.2.0 | 3.2.5 |
| `OpenEXR` | PyPI | From 3.3.0 | 3.3.6 |
| `OpenEXR` | PyPI | From 3.4.0 | 3.4.3 |

Products: Openexr Openexr.

## How do I fix CVE-2025-64183?

Upgrade openexr to a fixed version for your release line: 3.2.5, 3.3.6 or 3.4.3.

## Is CVE-2025-64183 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64183 exists.

## Other vulnerabilities in Openexr Openexr

- [CVE-2023-5841](https://insights.sbomify.com/CVE-2023-5841/): OpenEXR Heap Overflow in Scanline Deep Data Parsing (critical 9.1)
- [CVE-2026-41142](https://insights.sbomify.com/CVE-2026-41142/): OpenEXR is Vulnerable to Integer overflow in ImageChannel::resize leads to heap OOB write via OpenEXRUtil public API (high 8.8)
- [CVE-2026-42216](https://insights.sbomify.com/CVE-2026-42216/): OpenEXR: Out-of-bounds read in `IDManifest::init()` during prefix expansion (high 8.8)
- [CVE-2017-9111](https://insights.sbomify.com/CVE-2017-9111/): OpenEXR invalid write (high 8.8)
- [CVE-2017-9113](https://insights.sbomify.com/CVE-2017-9113/): Memory corruption in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64183 and fix it if it is affected.

What it is: CVE-2025-64183 is a medium-severity use after free vulnerability in Openexr Openexr, published on 10 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64183 exists.

Affected packages and fixed versions:
- openexr (PyPI): affected from 3.2.0; fixed in 3.2.5, 3.3.6, 3.4.3
- openexr (PyPI): affected from 3.2.0; fixed in 3.2.5
- openexr (PyPI): affected from 3.3.0; fixed in 3.3.6
- openexr (PyPI): affected from 3.4.0; fixed in 3.4.3
- OpenEXR (PyPI): affected from 3.2.0; fixed in 3.2.5
- OpenEXR (PyPI): affected from 3.3.0; fixed in 3.3.6
- OpenEXR (PyPI): affected from 3.4.0; fixed in 3.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64183/ (Markdown: https://insights.sbomify.com/CVE-2025-64183/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64183
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64183
- OSV: https://osv.dev/vulnerability/CVE-2025-64183

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64183/
Summaries are generated and may contain mistakes; the official description above is the record.
