# CVE-2025-64184: Dosage vulnerable to Directory Traversal through crafted HTTP responses

> A remote attacker can write arbitrary files outside the target directory by manipulating HTTP Content-Type headers during comic image downloads.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Nov 2025
- **Updated:** 7 Nov 2025
- **Also known as:** GHSA-4vcx-3pj3-44m7, PYSEC-2026-1316, UBUNTU-CVE-2025-64184

## What is CVE-2025-64184?

CVE-2025-64184 is a high-severity path traversal vulnerability in webcomics dosage, published on 7 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Dosage is a comic strip downloader and archiver. When downloading comic images in versions 3.1 and below, Dosage constructs target file names from different aspects of the remote comic (page URL, image URL, page content, etc.). While the basename is properly stripped of directory-traversing characters, the file extension is taken from the HTTP Content-Type header. This allows a remote attacker (or a Man-in-the-Middle, if the comic is served over HTTP) to write arbitrary files outside the target directory (if additional conditions are met). This issue is fixed in version 3.2.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-64184?

3 open source packages ship an affected version, including dosage.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dosage` | PyPI | All versions | 3.2 |
| `dosage` | PyPI | All versions | 3.2 |
| `dosage` | PyPI | All versions | 3.2 |

## How do I fix CVE-2025-64184?

Upgrade dosage to 3.2 or later.

## Is CVE-2025-64184 being exploited?

There is no known exploitation of CVE-2025-64184 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64184 and fix it if it is affected.

What it is: CVE-2025-64184 is a high-severity path traversal vulnerability in webcomics dosage, published on 7 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-64184 in the wild and no public exploit code.

Affected packages and fixed versions:
- dosage (PyPI): affected all versions; fixed in 3.2
- dosage (PyPI): affected all versions; fixed in 3.2
- dosage (PyPI): affected all versions; fixed in 3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64184/ (Markdown: https://insights.sbomify.com/CVE-2025-64184/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64184
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64184
- OSV: https://osv.dev/vulnerability/CVE-2025-64184

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64184/
Summaries are generated and may contain mistakes; the official description above is the record.
