# CVE-2025-64186: Evervault Go SDK: Incomplete PCR Validation in Enclave Attestation for non-Evervault hosted Enclaves

> Incomplete PCR validation in the Evervault Go SDK allows attackers to bypass enclave attestation checks, potentially trusting malicious enclaves.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Nov 2025
- **Updated:** 14 Nov 2025
- **Also known as:** GHSA-88h9-77c7-p6w4, GO-2025-4112

## What is CVE-2025-64186?

CVE-2025-64186 is a high-severity vulnerability in evervault-go, published on 12 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Evervault is a payment security solution. A vulnerability was identified in the `evervault-go` SDK’s attestation verification logic in versions of `evervault-go` prior to 1.3.2 that may allow incomplete documents to pass validation. This may cause the client to trust an enclave operator that does not meet expected integrity guarantees. The exploitability of this issue is limited in Evervault-hosted environments as an attacker would require the pre-requisite ability to serve requests from specific evervault domain names, following from our ACME challenge based TLS certificate acquisition pipeline. The vulnerability primarily affects applications which only check PCR8. Though the efficacy is also reduced for applications that check all PCR values, the impact is largely remediated by checking PCR 0, 1 and 2. The identified issue has been addressed in version 1.3.2 by validating attestation documents before storing in the cache, and replacing the naive equality checks with a new SatisfiedBy check. Those who useevervault-go to attest Enclaves that are hosted outside of Evervault environments and cannot upgrade have two possible workarounds available. Modify the application logic to fail verification if PCR8 is not explicitly present and non-empty and/or add custom pre-validation to reject documents that omit any required PCRs.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2025-64186?

3 open source packages ship an affected version, including github.com/evervault/evervault-go. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/evervault/evervault-go` | Go | All versions | 1.3.2 |
| `github.com/evervault/evervault-go` | Go | All versions | 1.3.2 |
| `github.com/evervault/evervault-go` | Go | All versions | 1.3.2 |

Products: Evervault Evervault.

## How do I fix CVE-2025-64186?

Upgrade github.com/evervault/evervault-go to 1.3.2 or later.

## Is CVE-2025-64186 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64186 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64186 and fix it if it is affected.

What it is: CVE-2025-64186 is a high-severity vulnerability in evervault-go, published on 12 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64186 exists.

Affected packages and fixed versions:
- github.com/evervault/evervault-go (Go): affected all versions; fixed in 1.3.2
- github.com/evervault/evervault-go (Go): affected all versions; fixed in 1.3.2
- github.com/evervault/evervault-go (Go): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64186/ (Markdown: https://insights.sbomify.com/CVE-2025-64186/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64186
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64186
- OSV: https://osv.dev/vulnerability/CVE-2025-64186

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64186/
Summaries are generated and may contain mistakes; the official description above is the record.
