# CVE-2025-64187: OctoPrint is vulnerable to XSS through Action Command Notifications and Prompts

> Attackers can inject malicious scripts via crafted print files, allowing them to execute code or steal data from the OctoPrint web interface.

- **Severity:** Medium 4.6 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:L/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Nov 2025
- **Updated:** 7 Nov 2025
- **Also known as:** GHSA-crvm-xjhm-9h29, PYSEC-2026-1714

## What is CVE-2025-64187?

CVE-2025-64187 is a medium-severity cross-site scripting vulnerability in OctoPrint, published on 7 Nov 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OctoPrint provides a web interface for controlling consumer 3D printers. Versions 1.11.3 and below are affected by a vulnerability that allows injection of arbitrary HTML and JavaScript into Action Command notifications and prompts popups generated by the printer. An attacker who successfully convinces a victim to print a specially crafted file could exploit this issue to disrupt ongoing prints, extract information (including sensitive configuration settings, if the targeted user has the necessary permissions for that), or perform other actions on behalf of the targeted user within the OctoPrint instance. This issue is fixed in version 1.11.4.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2025-64187?

3 open source packages ship an affected version, including octoprint. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `octoprint` | PyPI | All versions | 1.11.4 |
| `octoprint` | PyPI | All versions | 1.11.4 |
| `octoprint` | PyPI | All versions | 1.11.4 |

Products: Octoprint Octoprint.

## How do I fix CVE-2025-64187?

Upgrade octoprint to 1.11.4 or later.

## Is CVE-2025-64187 being exploited?

There is no known exploitation of CVE-2025-64187 in the wild and no public exploit code.

## Other vulnerabilities in OctoPrint

- [CVE-2018-16710](https://insights.sbomify.com/CVE-2018-16710/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-58180](https://insights.sbomify.com/CVE-2025-58180/): OctoPrint is Vulnerable to RCE Attacks via Unsanitized Filename in File Upload (high 7.5)
- [CVE-2022-1430](https://insights.sbomify.com/CVE-2022-1430/): Cross-site Scripting (XSS) - DOM in octoprint/octoprint (high 7.5)
- [CVE-2022-1432](https://insights.sbomify.com/CVE-2022-1432/): Cross-site Scripting (XSS) - Generic in octoprint/octoprint (high 7.5)
- [CVE-2024-32977](https://insights.sbomify.com/CVE-2024-32977/): OctoPrint Authentication Bypass via X-Forwarded-For Header when autologinLocal is enabled (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64187 and fix it if it is affected.

What it is: CVE-2025-64187 is a medium-severity cross-site scripting vulnerability in OctoPrint, published on 7 Nov 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-64187 in the wild and no public exploit code.

Affected packages and fixed versions:
- octoprint (PyPI): affected all versions; fixed in 1.11.4
- octoprint (PyPI): affected all versions; fixed in 1.11.4
- octoprint (PyPI): affected all versions; fixed in 1.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64187/ (Markdown: https://insights.sbomify.com/CVE-2025-64187/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64187
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64187
- OSV: https://osv.dev/vulnerability/CVE-2025-64187

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64187/
Summaries are generated and may contain mistakes; the official description above is the record.
