# CVE-2025-64323: kgateway is missing xDS authorization

> Attackers with network access to the xDS port can retrieve sensitive configuration data due to missing authentication in kgateway.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Nov 2025
- **Updated:** 7 Nov 2025
- **Also known as:** GHSA-4766-x535-jw3r, GO-2025-4094

## What is CVE-2025-64323?

CVE-2025-64323 is a medium-severity missing authorization vulnerability in kgateway-dev kgateway, published on 7 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

kgateway is a Cloud-Native API and AI Gateway. Versions 2.0.4 and below and 2.1.0-agw-cel-rbac through 2.1.0-rc.2 lack authentication, allowing any client with unrestricted network access to the xDS port to retrieve potentially sensitive configuration data including certificate data, backend service information, routing rules, and cluster metadata. This issue is solved in versions 2.0.5 and 2.1.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-64323?

6 open source packages ship an affected version, including github.com/kgateway-dev/kgateway/v2 and github.com/kgateway-dev/kgateway.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kgateway-dev/kgateway/v2` | Go | All versions | 2.0.5, 2.1.0 |
| `github.com/kgateway-dev/kgateway/v2` | Go | All versions | 2.0.5 |
| `github.com/kgateway-dev/kgateway/v2` | Go | All versions | 2.0.5 |
| `github.com/kgateway-dev/kgateway/v2` | Go | From 2.1.0-agw-cel-rbac | 2.1.0 |
| `github.com/kgateway-dev/kgateway/v2` | Go | From 2.1.0-agw-cel-rbac | 2.1.0 |
| `github.com/kgateway-dev/kgateway` | Go | All versions | None |

## How do I fix CVE-2025-64323?

Upgrade github.com/kgateway-dev/kgateway/v2 to a fixed version for your release line: 2.0.5 or 2.1.0.

## Is CVE-2025-64323 being exploited?

There is no known exploitation of CVE-2025-64323 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64323 and fix it if it is affected.

What it is: CVE-2025-64323 is a medium-severity missing authorization vulnerability in kgateway-dev kgateway, published on 7 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64323 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kgateway-dev/kgateway/v2 (Go): affected all versions; fixed in 2.0.5, 2.1.0
- github.com/kgateway-dev/kgateway/v2 (Go): affected all versions; fixed in 2.0.5
- github.com/kgateway-dev/kgateway/v2 (Go): affected all versions; fixed in 2.0.5
- github.com/kgateway-dev/kgateway/v2 (Go): affected from 2.1.0-agw-cel-rbac; fixed in 2.1.0
- github.com/kgateway-dev/kgateway/v2 (Go): affected from 2.1.0-agw-cel-rbac; fixed in 2.1.0
- github.com/kgateway-dev/kgateway (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64323/ (Markdown: https://insights.sbomify.com/CVE-2025-64323/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64323
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64323
- OSV: https://osv.dev/vulnerability/CVE-2025-64323

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64323/
Summaries are generated and may contain mistakes; the official description above is the record.
