# CVE-2025-64324: KubeVirt Vulnerable to Arbitrary Host File Read and Write

> An attacker can read and write arbitrary host files via the hostDisk feature, requiring specific configuration to exploit.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Nov 2025
- **Updated:** 26 Feb 2026
- **Also known as:** AZL-70414, AZL-70463, GHSA-46xp-26xh-hpqh, GO-2025-4110, MINI-2xm8-mcqj-cc35, MINI-f6cj-3wqj-m9f8, MINI-jmfp-8r4r-xr24, MINI-vrff-ggvj-52mh

## What is CVE-2025-64324?

CVE-2025-64324 is a high-severity path traversal vulnerability in kubevirt, published on 18 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

KubeVirt is a virtual machine management add-on for Kubernetes. The `hostDisk` feature in KubeVirt allows mounting a host file or directory owned by the user with UID 107 into a VM. However, prior to version 1.6.1 and 1.7.0, the implementation of this feature and more specifically the `DiskOrCreate` option (which creates a file if it doesn't exist) has a logic bug that allows an attacker to read and write arbitrary files owned by more privileged users on the host system. Versions 1.6.1 and 1.7.0 fix the issue.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-64324?

5 open source packages ship an affected version, including kubevirt.io/kubevirt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kubevirt.io/kubevirt` | Go | All versions | 1.6.1, 1.7.0-rc.0 |
| `kubevirt.io/kubevirt` | Go | All versions | 1.6.1 |
| `kubevirt.io/kubevirt` | Go | All versions | 1.6.1 |
| `kubevirt.io/kubevirt` | Go | From 1.7.0-alpha.0 | 1.7.0-rc.0 |
| `kubevirt.io/kubevirt` | Go | From 1.7.0-alpha.0 | 1.7.0-rc.0 |

Products: Kubevirt Kubevirt.

## How do I fix CVE-2025-64324?

Upgrade kubevirt.io/kubevirt to a fixed version for your release line: 1.6.1 or 1.7.0-rc.0.

## Is CVE-2025-64324 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64324 exists.

## Other vulnerabilities in kubevirt

- [CVE-2020-14316](https://insights.sbomify.com/CVE-2020-14316/): Privilege Escalation in kubevirt (critical 9.9)
- [CVE-2022-1798](https://insights.sbomify.com/CVE-2022-1798/): Path Traversal vulnerability in Kubevirt (high 8.7)
- [CVE-2023-26484](https://insights.sbomify.com/CVE-2023-26484/): On a compromised KubeVirt node, the virt-handler service account can be used to modify all node specs (high 8.2)
- [CVE-2026-13201](https://insights.sbomify.com/CVE-2026-13201/): Path traversal in Red Hat Container Native Virtualization 4.12 (high 7.3)
- [CVE-2025-64436](https://insights.sbomify.com/CVE-2025-64436/): KubeVirt Excessive Role Permissions Could Enable Unauthorized VMI Migrations Between Nodes (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64324 and fix it if it is affected.

What it is: CVE-2025-64324 is a high-severity path traversal vulnerability in kubevirt, published on 18 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64324 exists.

Affected packages and fixed versions:
- kubevirt.io/kubevirt (Go): affected all versions; fixed in 1.6.1, 1.7.0-rc.0
- kubevirt.io/kubevirt (Go): affected all versions; fixed in 1.6.1
- kubevirt.io/kubevirt (Go): affected all versions; fixed in 1.6.1
- kubevirt.io/kubevirt (Go): affected from 1.7.0-alpha.0; fixed in 1.7.0-rc.0
- kubevirt.io/kubevirt (Go): affected from 1.7.0-alpha.0; fixed in 1.7.0-rc.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64324/ (Markdown: https://insights.sbomify.com/CVE-2025-64324/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64324
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64324
- OSV: https://osv.dev/vulnerability/CVE-2025-64324

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64324/
Summaries are generated and may contain mistakes; the official description above is the record.
