CVE-2025-64325 Emby Server is Vulnerable to Remote Code Execution Through XSS in Admin Dashboard

High 8.4 Published Updated

Attackers can execute remote code via XSS in the admin dashboard by manipulating client headers, requiring an upgrade to secure the media server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2025-64325?

CVE-2025-64325 is a high-severity cross-site scripting vulnerability in EmbySupport Emby.Security, published on 18 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Emby Server is a personal media server. Prior to version 4.8.1.0 and prior to Beta version 4.9.0.0-beta, a malicious user can send an authentication request with a manipulated X-Emby-Client value, which gets added to the devices section of the admin dashboard without sanitization. This issue has been patched in version 4.8.1.0 and Beta version 4.9.0.0-beta.

Weakness: CWE-79, CWE-116

Which versions are affected by CVE-2025-64325?

It affects 1 product.

Products include Emby Emby.

How do I fix CVE-2025-64325?

No fix has been published for CVE-2025-64325 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-64325 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64325 exists.

Sources

Also known as GHSA-2gwc-988r-2r7x.

Is CVE-2025-64325 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free