{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64325 exists.","fix":"No fix has been published for CVE-2025-64325 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-64325 is a high-severity cross-site scripting vulnerability in EmbySupport Emby.Security, published on 18 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-64325 and fix it if it is affected.\n\nWhat it is: CVE-2025-64325 is a high-severity cross-site scripting vulnerability in EmbySupport Emby.Security, published on 18 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64325 exists.\n\nAffected product: EmbySupport Emby.Security. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64325/ (Markdown: https://insights.sbomify.com/CVE-2025-64325/index.md)","id":"CVE-2025-64325","markdown":"https://insights.sbomify.com/CVE-2025-64325/index.md","name":"CVE-2025-64325","record":{"aliases":["GHSA-2gwc-988r-2r7x"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Emby media server","requires_auth":"low_privilege","summary":"Attackers can execute remote code via XSS in the admin dashboard by manipulating client headers, requiring an upgrade to secure the media server.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"emby","vendor":"emby"}],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"Emby Server is a personal media server. Prior to version 4.8.1.0 and prior to Beta version 4.9.0.0-beta, a malicious user can send an authentication request with a manipulated X-Emby-Client value, which gets added to the devices section of the admin dashboard without sanitization. This issue has been patched in version 4.8.1.0 and Beta version 4.9.0.0-beta.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Emby Server is Vulnerable to Remote Code Execution Through XSS in Admin Dashboard","id":"CVE-2025-64325","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":0,"n_references":1,"next":{"headline":"Weblate leaks the IP of project members inviting users to assume reviewer roles in Audit log","id":"CVE-2025-64326"},"packages":[],"prev":{"headline":"KubeVirt Vulnerable to Arbitrary Host File Read and Write","id":"CVE-2025-64324"},"products":["Emby.Security"],"published":"2025-11-18","related":[{"cvss_score":9.8,"headline":"Auth bypass in n/a","id":"CVE-2021-25827","kev_date_added":null,"published":"2023-06-28"},{"cvss_score":9.8,"headline":"Server-side request forgery in n/a","id":"CVE-2020-26948","kev_date_added":null,"published":"2020-10-10"},{"cvss_score":9.3,"headline":"Emby Server allows attackers to gain administrative server access without preconditions","id":"CVE-2025-64113","kev_date_added":null,"published":"2025-12-09"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2021-25828","kev_date_added":null,"published":"2023-06-28"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2022-36223","kev_date_added":null,"published":"2022-12-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-19","vendors":["EmbySupport"]},"summary":"Attackers can execute remote code via XSS in the admin dashboard by manipulating client headers, requiring an upgrade to secure the media server.","url":"https://insights.sbomify.com/CVE-2025-64325/"}