CVE-2025-64328 Sangoma FreePBX OS Command Injection

Exploited in the wild High 8.6 Published Updated

Authenticated attackers can execute arbitrary commands via the filestore module, gaining remote access as the asterisk user.

Exploited in the wild
Since 3 Feb 2026
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-64328?

CVE-2025-64328 is a high-severity command injection vulnerability in FreePBX filestore, published on 7 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

FreePBX Endpoint Manager is a module for managing telephony endpoints in FreePBX systems. In versions 17.0.2.36 and above before 17.0.3, the filestore module within the Administrative interface is vulnerable to a post-authentication command injection by an authenticated known user via the testconnection -> check_ssh_connect() function. An attacker can leverage this vulnerability to obtain remote access to the system as an asterisk user. This issue is fixed in version 17.0.3.

Weakness: CWE-78

Which versions are affected by CVE-2025-64328?

It affects 1 product.

Products include Sangoma Filestore.

How do I fix CVE-2025-64328?

No fix has been published for CVE-2025-64328 yet. Limit exposure of the affected software until one is available. US federal agencies must fix it by 24 Feb 2026.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2025-64328 being exploited?

Yes. Attackers have exploited CVE-2025-64328 in the wild since at least 3 Feb 2026.

Public exploit code: 1 Metasploit module, 1 Nuclei template and 1 proofs of concept on GitHub.

Sources

Also known as GHSA-vm9p-46mv-5xvw.

Is CVE-2025-64328 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free