# CVE-2025-64328: Sangoma FreePBX OS Command Injection

> Authenticated attackers can execute arbitrary commands via the filestore module, gaining remote access as the asterisk user.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Yes, since 3 Feb 2026 (CISA KEV)
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Nov 2025
- **Updated:** 13 Feb 2026
- **Also known as:** GHSA-vm9p-46mv-5xvw

## What is CVE-2025-64328?

CVE-2025-64328 is a high-severity command injection vulnerability in FreePBX filestore, published on 7 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

FreePBX Endpoint Manager is a module for managing telephony endpoints in FreePBX systems. In versions 17.0.2.36 and above before 17.0.3, the filestore module within the Administrative interface is vulnerable to a post-authentication command injection by an authenticated known user via the testconnection -> check_ssh_connect() function. An attacker can leverage this vulnerability to obtain remote access to the system as an asterisk user. This issue is fixed in version 17.0.3.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-64328?

It affects 1 product.


Products: Sangoma Filestore.

## How do I fix CVE-2025-64328?

No fix has been published for CVE-2025-64328 yet. Limit exposure of the affected software until one is available. US federal agencies must fix it by 24 Feb 2026.

## Is CVE-2025-64328 being exploited?

Yes. Attackers have exploited CVE-2025-64328 in the wild since at least 3 Feb 2026.

Public exploit code:

- FreePBX filestore authenticated command injection (metasploit)
- CVE-2025-64328 FreePBX Authenticated Command Injection in the framework module. (github_poc): https://github.com/mcorybillington/CVE-2025-64328_FreePBX-framework-Command-Injection
- FreePBX  >= 17.0.2.36 && < 17.0.3 - Authenticated Command Injection (nuclei): http/cves/2025/CVE-2025-64328.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64328 and fix it if it is affected.

What it is: CVE-2025-64328 is a high-severity command injection vulnerability in FreePBX filestore, published on 7 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2025-64328 in the wild since at least 3 Feb 2026.

Affected product: FreePBX filestore. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64328/ (Markdown: https://insights.sbomify.com/CVE-2025-64328/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64328
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64328
- OSV: https://osv.dev/vulnerability/CVE-2025-64328

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64328/
Summaries are generated and may contain mistakes; the official description above is the record.
