# CVE-2025-64343: (conda) Constructor: Excessive permissions during and after installation

> Local attackers can modify conda installations due to excessive directory permissions inherited from parent folders, potentially leading to privilege escalation.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Nov 2025
- **Updated:** 7 Nov 2025
- **Also known as:** GHSA-vvpr-2qg4-2mrq

## What is CVE-2025-64343?

CVE-2025-64343 is a high-severity vulnerability in conda constructor, published on 7 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

(conda) Constructor is a tool that enables users to create installers for conda package collections. In versions 3.12.2 and below, the  installation directory inherits permissions from its parent directory. Outside of restricted directories, the permissions are very permissive and often allow write access by authenticated users. Any logged in user can make modifications during the installation for both single-user and all-user installations. This constitutes a local attack vector if the installation is in a directory local users have access to. For single-user installations in a shared directory, these permissions persist after the installation. This issue is fixed in version 3.13.0.

Weakness: CWE-289 (Authentication Bypass by Alternate Name)

## Which versions are affected by CVE-2025-64343?


## How do I fix CVE-2025-64343?

No fix has been published for CVE-2025-64343 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-64343 being exploited?

There is no known exploitation of CVE-2025-64343 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64343 and fix it if it is affected.

What it is: CVE-2025-64343 is a high-severity vulnerability in conda constructor, published on 7 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64343 in the wild and no public exploit code.

Affected product: conda constructor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64343/ (Markdown: https://insights.sbomify.com/CVE-2025-64343/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64343
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64343
- OSV: https://osv.dev/vulnerability/CVE-2025-64343

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64343/
Summaries are generated and may contain mistakes; the official description above is the record.
