# CVE-2025-64344: Suricata is vulnerable to a stack overflow from unbounded stack allocation in LuaPushStringBuffer

> Attackers can cause a stack overflow in Suricata by triggering large buffer allocations in Lua scripts, leading to denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Nov 2025
- **Updated:** 28 Nov 2025
- **Also known as:** DEBIAN-CVE-2025-64344, GHSA-93fh-cgmc-w3rx, UBUNTU-CVE-2025-64344

## What is CVE-2025-64344?

CVE-2025-64344 is a high-severity memory corruption vulnerability in Oisf Suricata, published on 26 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Suricata is a network IDS, IPS and NSM engine developed by the OISF (Open Information Security Foundation) and the Suricata community. Prior to versions 7.0.13 and 8.0.2, working with large buffers in Lua scripts can lead to a stack overflow. Users of Lua rules and output scripts may be affected when working with large buffers. This includes a rule passing a large buffer to a Lua script. This issue has been patched in versions 7.0.13 and 8.0.2. A workaround for this issue involves disabling Lua rules and output scripts, or making sure limits, such as stream.depth.reassembly and HTTP response body limits (response-body-limit), are set to less than half the stack size.

Weakness: CWE-787 (Out-of-bounds Write), CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2025-64344?

It affects 1 product.


Products: Oisf Suricata.

## How do I fix CVE-2025-64344?

Upgrade to a fixed version.

## Is CVE-2025-64344 being exploited?

There is no known exploitation of CVE-2025-64344 in the wild and no public exploit code.

## Other vulnerabilities in Oisf Suricata

- [CVE-2023-35853](https://insights.sbomify.com/CVE-2023-35853/): Code injection in n/a (critical 9.8)
- [CVE-2021-37592](https://insights.sbomify.com/CVE-2021-37592/): Other in n/a (critical 9.8)
- [CVE-2018-10244](https://insights.sbomify.com/CVE-2018-10244/): Integer overflow in n/a (critical 9.8)
- [CVE-2026-94083](https://insights.sbomify.com/CVE-2026-94083/): Memory corruption in Suricata (critical 9.4)
- [CVE-2026-94084](https://insights.sbomify.com/CVE-2026-94084/): Use after free in Suricata (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64344 and fix it if it is affected.

What it is: CVE-2025-64344 is a high-severity memory corruption vulnerability in Oisf Suricata, published on 26 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64344 in the wild and no public exploit code.

Affected product: Oisf Suricata. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64344/ (Markdown: https://insights.sbomify.com/CVE-2025-64344/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64344
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64344
- OSV: https://osv.dev/vulnerability/CVE-2025-64344

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64344/
Summaries are generated and may contain mistakes; the official description above is the record.
