# CVE-2025-64346: archives: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

> A path traversal vulnerability in the Go archives library allows attackers to execute code or modify files via malicious archives.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Nov 2025
- **Updated:** 7 Nov 2025
- **Also known as:** GHSA-j95m-rcjp-q69h, GO-2025-3581

## What is CVE-2025-64346?

CVE-2025-64346 is a medium-severity path traversal vulnerability in jaredallard archives, published on 7 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

archives is a Go library for extracting archives (tar, zip, etc.). Version 1.0.0 does not prevent a malicious user to feed a specially crafted archive to the library causing RCE, modification of files or other malignancies in the context of whatever the user is running this library as, through the program that imports it. Severity depends on user permissions, environment and how arbitrary archives are passed. This issue is fixed in version 1.0.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-64346?

3 open source packages ship an affected version, including github.com/jaredallard/archives.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/jaredallard/archives` | Go | All versions | 1.0.1 |
| `github.com/jaredallard/archives` | Go | All versions | 1.0.1 |
| `github.com/jaredallard/archives` | Go | All versions | 1.0.1 |

## How do I fix CVE-2025-64346?

Upgrade github.com/jaredallard/archives to 1.0.1 or later.

## Is CVE-2025-64346 being exploited?

There is no known exploitation of CVE-2025-64346 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64346 and fix it if it is affected.

What it is: CVE-2025-64346 is a medium-severity path traversal vulnerability in jaredallard archives, published on 7 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64346 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/jaredallard/archives (Go): affected all versions; fixed in 1.0.1
- github.com/jaredallard/archives (Go): affected all versions; fixed in 1.0.1
- github.com/jaredallard/archives (Go): affected all versions; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64346/ (Markdown: https://insights.sbomify.com/CVE-2025-64346/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64346
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64346
- OSV: https://osv.dev/vulnerability/CVE-2025-64346

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64346/
Summaries are generated and may contain mistakes; the official description above is the record.
