CVE-2025-64401 Apache OpenOffice: Remote documents loaded without prompt via IFrame

High 7.5 Published Updated

Attackers can craft documents that load external content without user prompts, bypassing security controls in Apache OpenOffice.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-64401?

CVE-2025-64401 is a high-severity missing authorization vulnerability in Apache Openoffice, published on 12 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Apache OpenOffice documents can contain links. A missing Authorization vulnerability in Apache OpenOffice allowed an attacker to craft a document that would cause external links to be loaded without prompt. In the affected versions of Apache OpenOffice, documents that used "floating frames" linked to external files would load the contents of those frames without prompting the user for permission to do so.

This issue affects Apache OpenOffice: through 4.1.15.

Users are recommended to upgrade to version 4.1.16, which fixes the issue.

The LibreOffice suite reported this issue as CVE-2023-2255

Weakness: CWE-862

Which versions are affected by CVE-2025-64401?

It affects 1 product.

Products include Apache Openoffice.

How do I fix CVE-2025-64401?

No fix has been published for CVE-2025-64401 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-64401 being exploited?

There is no known exploitation of CVE-2025-64401 in the wild and no public exploit code.

All Apache Openoffice vulnerabilities

Sources

Also known as GHSA-7cr9-pfmp-g6m2.

Is CVE-2025-64401 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free