CVE-2025-64406 Apache OpenOffice: Possible memory corruption during CSV import

Medium 4.3 Published Updated

An attacker can craft a malicious CSV document to cause memory corruption, potentially leading to code execution or application crashes in Apache OpenOffice.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2025-64406?

CVE-2025-64406 is a medium-severity memory corruption vulnerability in Apache Openoffice, published on 12 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

An out-of-bounds Write vulnerability in Apache OpenOffice could allow an attacker to craft a document that would crash the program, or otherwise corrupt other memory areas.

This issue affects Apache OpenOffice: through 4.1.15.

Users are recommended to upgrade to version 4.1.16, which fixes the issue.

Weakness: CWE-787

Which versions are affected by CVE-2025-64406?

It affects 1 product.

Products include Apache Openoffice.

How do I fix CVE-2025-64406?

No fix has been published for CVE-2025-64406 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2025-64406 being exploited?

There is no known exploitation of CVE-2025-64406 in the wild and no public exploit code.

All Apache Openoffice vulnerabilities

Sources

Also known as GHSA-fj59-gg5v-953f.

Is CVE-2025-64406 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free