# CVE-2025-64406: Apache OpenOffice: Possible memory corruption during CSV import

> An attacker can craft a malicious CSV document to cause memory corruption, potentially leading to code execution or application crashes in Apache OpenOffice.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 12 Nov 2025
- **Updated:** 12 Nov 2025
- **Also known as:** GHSA-fj59-gg5v-953f

## What is CVE-2025-64406?

CVE-2025-64406 is a medium-severity memory corruption vulnerability in Apache Openoffice, published on 12 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An out-of-bounds Write vulnerability in Apache OpenOffice could allow an attacker to craft a document that would crash the program, or otherwise corrupt other memory areas.

This issue affects Apache OpenOffice: through 4.1.15.

Users are recommended to upgrade to version 4.1.16, which fixes the issue.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2025-64406?

It affects 1 product.


Products: Apache Openoffice.

## How do I fix CVE-2025-64406?

No fix has been published for CVE-2025-64406 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-64406 being exploited?

There is no known exploitation of CVE-2025-64406 in the wild and no public exploit code.

## Other vulnerabilities in Apache Openoffice

- [CVE-2014-3524](https://insights.sbomify.com/CVE-2014-3524/): Command injection in n/a (critical 9.3)
- [CVE-2010-3450](https://insights.sbomify.com/CVE-2010-3450/): Path traversal in n/a (critical 9.3)
- [CVE-2010-3451](https://insights.sbomify.com/CVE-2010-3451/): Use after free in n/a (critical 9.3)
- [CVE-2010-3452](https://insights.sbomify.com/CVE-2010-3452/): Use after free in n/a (critical 9.3)
- [CVE-2010-3453](https://insights.sbomify.com/CVE-2010-3453/): Memory corruption in n/a (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64406 and fix it if it is affected.

What it is: CVE-2025-64406 is a medium-severity memory corruption vulnerability in Apache Openoffice, published on 12 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-64406 in the wild and no public exploit code.

Affected product: Apache Openoffice. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64406/ (Markdown: https://insights.sbomify.com/CVE-2025-64406/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64406
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64406
- OSV: https://osv.dev/vulnerability/CVE-2025-64406

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64406/
Summaries are generated and may contain mistakes; the official description above is the record.
