CVE-2025-64407 Apache OpenOffice: URL fetching can be used to exfiltrate arbitrary INI file values and environment variables

Medium 5.3 Published Updated

Attackers can craft documents to exfiltrate system information like environment variables and INI files without user prompts.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-64407?

CVE-2025-64407 is a medium-severity missing authorization vulnerability in Apache Openoffice, published on 12 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Apache OpenOffice documents can contain links. A missing Authorization vulnerability in Apache OpenOffice allowed an attacker to craft a document that would cause external links to be loaded without prompt. Such links could also be used to transmit system information, such as environment variables or configuration settings.

In the affected versions of Apache OpenOffice, documents that used a certain URI scheme linking to external files would load the contents of such files without prompting the user for permission to do so. Such URI scheme allows to include system configuration data, that is not supposed to be transmitted externally.

This issue affects Apache OpenOffice: through 4.1.15.

Users are recommended to upgrade to version 4.1.16, which fixes the issue.

The LibreOffice suite reported this issue as CVE-2024-12426.

Weakness: CWE-862, CWE-201

Which versions are affected by CVE-2025-64407?

It affects 1 product.

Products include Apache Openoffice.

How do I fix CVE-2025-64407?

No fix has been published for CVE-2025-64407 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-64407 being exploited?

There is no known exploitation of CVE-2025-64407 in the wild and no public exploit code.

All Apache Openoffice vulnerabilities

Sources

Also known as GHSA-wgcp-cg6f-7679.

Is CVE-2025-64407 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free