# CVE-2025-64407: Apache OpenOffice: URL fetching can be used to exfiltrate arbitrary INI file values and environment variables

> Attackers can craft documents to exfiltrate system information like environment variables and INI files without user prompts.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Nov 2025
- **Updated:** 13 Nov 2025
- **Also known as:** GHSA-wgcp-cg6f-7679

## What is CVE-2025-64407?

CVE-2025-64407 is a medium-severity missing authorization vulnerability in Apache Openoffice, published on 12 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache OpenOffice documents can contain links. A missing Authorization vulnerability in Apache OpenOffice allowed an attacker to craft a document that would cause external links 
to be loaded without prompt. Such links could also be used to transmit system information, such as environment variables or configuration settings.

In the affected versions of Apache OpenOffice, documents that used a certain URI scheme linking to external files would 
load the contents of such files without prompting the user for 
permission to do so. Such URI scheme allows to include system configuration data, that is not supposed to be transmitted externally.

This issue affects Apache OpenOffice: through 4.1.15.

Users are recommended to upgrade to version 4.1.16, which fixes the issue.

The LibreOffice suite reported this issue as CVE-2024-12426.

Weakness: CWE-862 (Missing Authorization), CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2025-64407?

It affects 1 product.


Products: Apache Openoffice.

## How do I fix CVE-2025-64407?

No fix has been published for CVE-2025-64407 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-64407 being exploited?

There is no known exploitation of CVE-2025-64407 in the wild and no public exploit code.

## Other vulnerabilities in Apache Openoffice

- [CVE-2014-3524](https://insights.sbomify.com/CVE-2014-3524/): Command injection in n/a (critical 9.3)
- [CVE-2010-3450](https://insights.sbomify.com/CVE-2010-3450/): Path traversal in n/a (critical 9.3)
- [CVE-2010-3451](https://insights.sbomify.com/CVE-2010-3451/): Use after free in n/a (critical 9.3)
- [CVE-2010-3452](https://insights.sbomify.com/CVE-2010-3452/): Use after free in n/a (critical 9.3)
- [CVE-2010-3453](https://insights.sbomify.com/CVE-2010-3453/): Memory corruption in n/a (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64407 and fix it if it is affected.

What it is: CVE-2025-64407 is a medium-severity missing authorization vulnerability in Apache Openoffice, published on 12 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64407 in the wild and no public exploit code.

Affected product: Apache Openoffice. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64407/ (Markdown: https://insights.sbomify.com/CVE-2025-64407/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64407
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64407
- OSV: https://osv.dev/vulnerability/CVE-2025-64407

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64407/
Summaries are generated and may contain mistakes; the official description above is the record.
