{"answers":{"affected":"8 open source packages ship an affected version, including org.apache.causeway.commons:causeway-commons, org.apache.causeway.core:causeway-applib and org.apache.causeway.core:causeway-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-64408 in the wild and no public exploit code.","fix":"Upgrade org.apache.causeway.commons:causeway-commons to 3.5.0 or later.","what":"CVE-2025-64408 is a medium-severity unsafe deserialization vulnerability in Apache Causeway, published on 19 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-64408 and fix it if it is affected.\n\nWhat it is: CVE-2025-64408 is a medium-severity unsafe deserialization vulnerability in Apache Causeway, published on 19 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-64408 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.causeway.commons:causeway-commons (Maven): affected all versions; fixed in 3.5.0\n- org.apache.causeway.commons:causeway-commons (Maven): affected all versions; fixed in 3.5.0\n- org.apache.causeway.core:causeway-applib (Maven): affected all versions; fixed in 3.5.0\n- org.apache.causeway.core:causeway-applib (Maven): affected all versions; fixed in 3.5.0\n- org.apache.causeway.core:causeway-core (Maven): affected all versions; fixed in 3.5.0\n- org.apache.causeway.core:causeway-core (Maven): affected all versions; fixed in 3.5.0\n- org.apache.causeway.viewer:causeway-viewer-wicket (Maven): affected all versions; fixed in 3.5.0\n- org.apache.causeway.viewer:causeway-viewer-wicket (Maven): affected all versions; fixed in 3.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64408/ (Markdown: https://insights.sbomify.com/CVE-2025-64408/index.md)","id":"CVE-2025-64408","markdown":"https://insights.sbomify.com/CVE-2025-64408/index.md","name":"CVE-2025-64408","record":{"aliases":["GHSA-wq4c-57mh-5f7g"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java application framework","requires_auth":"low_privilege","summary":"Authenticated attackers can achieve remote code execution via Java deserialization in Apache Causeway ViewModel functionality.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"causeway","vendor":"apache"}],"cvss":{"score":6.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Apache Causeway faces Java deserialization vulnerabilities that allow remote code execution (RCE) through user-controllable URL parameters. These vulnerabilities affect all applications using Causeway's ViewModel functionality and can be exploited by authenticated attackers to execute arbitrary code with application privileges. \n\nThis issue affects all current versions.\n\nUsers are recommended to upgrade to version 3.5.0, which fixes the issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Causeway: Java deserialization vulnerability to authenticated attackers","id":"CVE-2025-64408","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":8,"n_references":1,"next":{"headline":"Coolify vulnerable to command injection via docker-compose.yaml parameters","id":"CVE-2025-64419"},"packages":[{"ecosystem":"Maven","fixed":["3.5.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.causeway.commons:causeway-commons","purl":null,"source":"GHSA-wq4c-57mh-5f7g"},{"ecosystem":"Maven","fixed":["3.5.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.causeway.commons:causeway-commons","purl":"pkg:maven/org.apache.causeway.commons/causeway-commons","source":"GHSA-wq4c-57mh-5f7g"},{"ecosystem":"Maven","fixed":["3.5.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.causeway.core:causeway-applib","purl":null,"source":"GHSA-wq4c-57mh-5f7g"},{"ecosystem":"Maven","fixed":["3.5.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.causeway.core:causeway-applib","purl":"pkg:maven/org.apache.causeway.core/causeway-applib","source":"GHSA-wq4c-57mh-5f7g"},{"ecosystem":"Maven","fixed":["3.5.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.causeway.core:causeway-core","purl":null,"source":"GHSA-wq4c-57mh-5f7g"},{"ecosystem":"Maven","fixed":["3.5.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.causeway.core:causeway-core","purl":"pkg:maven/org.apache.causeway.core/causeway-core","source":"GHSA-wq4c-57mh-5f7g"},{"ecosystem":"Maven","fixed":["3.5.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.causeway.viewer:causeway-viewer-wicket","purl":null,"source":"GHSA-wq4c-57mh-5f7g"},{"ecosystem":"Maven","fixed":["3.5.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.causeway.viewer:causeway-viewer-wicket","purl":"pkg:maven/org.apache.causeway.viewer/causeway-viewer-wicket","source":"GHSA-wq4c-57mh-5f7g"}],"prev":{"headline":"Apache OpenOffice: URL fetching can be used to exfiltrate arbitrary INI file values and environment variables","id":"CVE-2025-64407"},"products":["Apache Causeway"],"published":"2025-11-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-26","vendors":["Apache Software Foundation"]},"summary":"Authenticated attackers can achieve remote code execution via Java deserialization in Apache Causeway ViewModel functionality.","url":"https://insights.sbomify.com/CVE-2025-64408/"}