# CVE-2025-64408: Apache Causeway: Java deserialization vulnerability to authenticated attackers

> Authenticated attackers can achieve remote code execution via Java deserialization in Apache Causeway ViewModel functionality.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Nov 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-wq4c-57mh-5f7g

## What is CVE-2025-64408?

CVE-2025-64408 is a medium-severity unsafe deserialization vulnerability in Apache Causeway, published on 19 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Causeway faces Java deserialization vulnerabilities that allow remote code execution (RCE) through user-controllable URL parameters. These vulnerabilities affect all applications using Causeway's ViewModel functionality and can be exploited by authenticated attackers to execute arbitrary code with application privileges. 

This issue affects all current versions.

Users are recommended to upgrade to version 3.5.0, which fixes the issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-64408?

8 open source packages ship an affected version, including org.apache.causeway.commons:causeway-commons, org.apache.causeway.core:causeway-applib and org.apache.causeway.core:causeway-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.causeway.commons:causeway-commons` | Maven | All versions | 3.5.0 |
| `org.apache.causeway.commons:causeway-commons` | Maven | All versions | 3.5.0 |
| `org.apache.causeway.core:causeway-applib` | Maven | All versions | 3.5.0 |
| `org.apache.causeway.core:causeway-applib` | Maven | All versions | 3.5.0 |
| `org.apache.causeway.core:causeway-core` | Maven | All versions | 3.5.0 |
| `org.apache.causeway.core:causeway-core` | Maven | All versions | 3.5.0 |
| `org.apache.causeway.viewer:causeway-viewer-wicket` | Maven | All versions | 3.5.0 |
| `org.apache.causeway.viewer:causeway-viewer-wicket` | Maven | All versions | 3.5.0 |

Products: Apache Causeway.

## How do I fix CVE-2025-64408?

Upgrade org.apache.causeway.commons:causeway-commons to 3.5.0 or later.

## Is CVE-2025-64408 being exploited?

There is no known exploitation of CVE-2025-64408 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64408 and fix it if it is affected.

What it is: CVE-2025-64408 is a medium-severity unsafe deserialization vulnerability in Apache Causeway, published on 19 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64408 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.causeway.commons:causeway-commons (Maven): affected all versions; fixed in 3.5.0
- org.apache.causeway.commons:causeway-commons (Maven): affected all versions; fixed in 3.5.0
- org.apache.causeway.core:causeway-applib (Maven): affected all versions; fixed in 3.5.0
- org.apache.causeway.core:causeway-applib (Maven): affected all versions; fixed in 3.5.0
- org.apache.causeway.core:causeway-core (Maven): affected all versions; fixed in 3.5.0
- org.apache.causeway.core:causeway-core (Maven): affected all versions; fixed in 3.5.0
- org.apache.causeway.viewer:causeway-viewer-wicket (Maven): affected all versions; fixed in 3.5.0
- org.apache.causeway.viewer:causeway-viewer-wicket (Maven): affected all versions; fixed in 3.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64408/ (Markdown: https://insights.sbomify.com/CVE-2025-64408/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64408
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64408
- OSV: https://osv.dev/vulnerability/CVE-2025-64408

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64408/
Summaries are generated and may contain mistakes; the official description above is the record.
