{"answers":{"affected":"2 open source packages ship an affected version, including webrick. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-6442 in the wild and no public exploit code.","fix":"Upgrade webrick to 1.8.2 or later.","what":"CVE-2025-6442 is a medium-severity vulnerability in Ruby WEBrick, published on 25 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-6442 and fix it if it is affected.\n\nWhat it is: CVE-2025-6442 is a medium-severity vulnerability in Ruby WEBrick, published on 25 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-6442 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- webrick (RubyGems): affected all versions; fixed in 1.8.2\n- webrick (RubyGems): affected all versions; fixed in 1.8.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-6442/ (Markdown: https://insights.sbomify.com/CVE-2025-6442/index.md)","id":"CVE-2025-6442","markdown":"https://insights.sbomify.com/CVE-2025-6442/index.md","name":"CVE-2025-6442","record":{"aliases":["AZL-64352","AZL-64355","AZL-64364","AZL-64367","DEBIAN-CVE-2025-6442","GHSA-r995-q44h-hr64","OESA-2025-1930","UBUNTU-CVE-2025-6442","USN-7709-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Ruby WEBrick server","requires_auth":"none","summary":"Remote attackers can smuggle arbitrary HTTP requests in Ruby WEBrick when deployed behind a specific HTTP proxy, bypassing security controls.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"zdi","cpe":[{"product":"webrick","vendor":"ruby-lang"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"Ruby WEBrick read_header HTTP Request Smuggling Vulnerability. This vulnerability allows remote attackers to smuggle arbitrary HTTP requests on affected installations of Ruby WEBrick. This issue is exploitable when the product is deployed behind an HTTP proxy that fulfills specific conditions.\n\nThe specific flaw exists within the read_headers method. The issue results from the inconsistent parsing of terminators of HTTP headers. An attacker can leverage this vulnerability to smuggle arbitrary HTTP requests. Was ZDI-CAN-21876.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ruby WEBrick read_header HTTP Request Smuggling Vulnerability","id":"CVE-2025-6442","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"other","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Mikrotik RouterOS VXLAN Source IP Improper Access Control Vulnerability","id":"CVE-2025-6443"},"packages":[{"ecosystem":"RubyGems","fixed":["1.8.2"],"introduced":["0"],"last_affected":[],"package":"webrick","purl":null,"source":"GHSA-r995-q44h-hr64"},{"ecosystem":"RubyGems","fixed":["1.8.2"],"introduced":["0"],"last_affected":[],"package":"webrick","purl":"pkg:gem/webrick","source":"GHSA-r995-q44h-hr64"}],"prev":{"headline":"Auth bypass in WebinarIgnition – Live, Automated \u0026 Evergreen Webinars for WooCommerce","id":"CVE-2025-6441"},"products":["WEBrick"],"published":"2025-06-25","related":[{"cvss_score":7.5,"headline":"WEBrick Improper Input Validation vulnerability","id":"CVE-2009-4492","kev_date_added":null,"published":"2010-01-13"},{"cvss_score":5.5,"headline":"Path traversal in n/a","id":"CVE-2019-11879","kev_date_added":null,"published":"2019-05-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-25","vendors":["Ruby"]},"summary":"Remote attackers can smuggle arbitrary HTTP requests in Ruby WEBrick when deployed behind a specific HTTP proxy, bypassing security controls.","url":"https://insights.sbomify.com/CVE-2025-6442/"}