CVE-2025-64428 DataEase DB2 JNDI Vulnerability

High 8.9 Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2025-64428?

CVE-2025-64428 is a high-severity vulnerability in Dataease Dataease, published on 20 Nov 2025.

Official description

Dataease is an open source data visualization analysis tool. Versions prior to 2.10.17 are vulnerable to JNDI injection. A blacklist was added in the patch for version 2.10.14. However, JNDI injection remains possible via the iiop, corbaname, and iiopname schemes. The vulnerability has been fixed in version 2.10.17.

Weakness: CWE-74

Which versions are affected by CVE-2025-64428?

It affects 1 product.

Products include Dataease Dataease.

How do I fix CVE-2025-64428?

No fix has been published for CVE-2025-64428 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-64428 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64428 exists.

All Dataease Dataease vulnerabilities

Sources

Also known as GHSA-88ph-3236-2m2h.

Is CVE-2025-64428 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free