{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64428 exists.","fix":"No fix has been published for CVE-2025-64428 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-64428 is a high-severity vulnerability in Dataease Dataease, published on 20 Nov 2025."},"fix_prompt":"Check this codebase for CVE-2025-64428 and fix it if it is affected.\n\nWhat it is: CVE-2025-64428 is a high-severity vulnerability in Dataease Dataease, published on 20 Nov 2025. \nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64428 exists.\n\nAffected product: Dataease Dataease. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64428/ (Markdown: https://insights.sbomify.com/CVE-2025-64428/index.md)","id":"CVE-2025-64428","markdown":"https://insights.sbomify.com/CVE-2025-64428/index.md","name":"CVE-2025-64428","record":{"aliases":["GHSA-88ph-3236-2m2h"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"dataease","vendor":"dataease"}],"cvss":{"score":8.9,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"Dataease is an open source data visualization analysis tool. Versions prior to 2.10.17 are vulnerable to JNDI injection. A blacklist was added in the patch for version 2.10.14. However, JNDI injection remains possible via the iiop, corbaname, and iiopname schemes. The vulnerability has been fixed in version 2.10.17.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"DataEase DB2 JNDI Vulnerability","id":"CVE-2025-64428","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"dataease:dataease","products":["dataease:dataease"],"type":null,"year":"2025"},"n_packages":0,"n_references":3,"next":{"headline":"DuckDB Encryption Crypto implementation is vulnerable","id":"CVE-2025-64429"},"packages":[],"prev":{"headline":"ZimaOS is vulnerable to Server-Side Request Forgery (SSRF)","id":"CVE-2025-64427"},"products":["dataease"],"published":"2025-11-20","related":[{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2024-57707","kev_date_added":null,"published":"2025-02-07"},{"cvss_score":9.8,"headline":"DataEase's H2 datasource has a remote command execution risk","id":"CVE-2024-46997","kev_date_added":null,"published":"2024-09-23"},{"cvss_score":9.8,"headline":"DataEase data source has deserialization vulnerability","id":"CVE-2023-33963","kev_date_added":null,"published":"2023-06-01"},{"cvss_score":9.8,"headline":"SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed","id":"CVE-2023-28437","kev_date_added":null,"published":"2023-03-24"},{"cvss_score":9.8,"headline":"Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability","id":"CVE-2022-39312","kev_date_added":null,"published":"2022-10-25"},{"cvss_score":9.8,"headline":"Dataease before 1.11.2 allows arbitrary code execution via crafter plugin","id":"CVE-2022-34113","kev_date_added":null,"published":"2022-07-22"},{"cvss_score":9.8,"headline":"Dataease v1.11.1 SQL Injection via parameter dataSourceId","id":"CVE-2022-34115","kev_date_added":null,"published":"2022-07-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-21","vendors":["dataease"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2025-64428/"}