# CVE-2025-64428: DataEase DB2 JNDI Vulnerability


- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 20 Nov 2025
- **Updated:** 21 Nov 2025
- **Also known as:** GHSA-88ph-3236-2m2h

## What is CVE-2025-64428?

CVE-2025-64428 is a high-severity vulnerability in Dataease Dataease, published on 20 Nov 2025. 

### Official description

Dataease is an open source data visualization analysis tool. Versions prior to 2.10.17 are vulnerable to JNDI injection. A blacklist was added in the patch for version 2.10.14. However, JNDI injection remains possible via the iiop, corbaname, and iiopname schemes. The vulnerability has been fixed in version 2.10.17.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2025-64428?

It affects 1 product.


Products: Dataease Dataease.

## How do I fix CVE-2025-64428?

No fix has been published for CVE-2025-64428 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-64428 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64428 exists.

## Other vulnerabilities in Dataease Dataease

- [CVE-2024-57707](https://insights.sbomify.com/CVE-2024-57707/): Code injection in n/a (critical 9.8)
- [CVE-2024-46997](https://insights.sbomify.com/CVE-2024-46997/): DataEase's H2 datasource has a remote command execution risk (critical 9.8)
- [CVE-2023-33963](https://insights.sbomify.com/CVE-2023-33963/): DataEase data source has deserialization vulnerability (critical 9.8)
- [CVE-2023-28437](https://insights.sbomify.com/CVE-2023-28437/): SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed (critical 9.8)
- [CVE-2022-39312](https://insights.sbomify.com/CVE-2022-39312/): Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64428 and fix it if it is affected.

What it is: CVE-2025-64428 is a high-severity vulnerability in Dataease Dataease, published on 20 Nov 2025. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64428 exists.

Affected product: Dataease Dataease. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64428/ (Markdown: https://insights.sbomify.com/CVE-2025-64428/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64428
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64428
- OSV: https://osv.dev/vulnerability/CVE-2025-64428

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64428/
Summaries are generated and may contain mistakes; the official description above is the record.
