CVE-2025-64430 Parse Server Vulnerable to Server-Side Request Forgery (SSRF) in File Upload via URI Format
Attackers can trigger Server-Side Request Forgery via file upload URIs, potentially reading internal data or causing server crashes.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-64430?
CVE-2025-64430 is a high-severity server-side request forgery vulnerability in parse-community parse-server, published on 7 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions 4.2.0 through 7.5.3, and 8.0.0 through 8.3.1-alpha.1, there is a Server-Side Request Forgery (SSRF) vulnerability in the file upload functionality when trying to upload a Parse.File with uri parameter, allowing execution of an arbitrary URI. The vulnerability stems from a file upload feature in which Parse Server retrieves the file data from a URI that is provided in the request. A request to the provided URI is executed, but the response is not stored in Parse Server's file storage as the server crashes upon receiving the response. This issue is fixed in versions 7.5.4 and 8.4.0-alpha.1.
Weakness: CWE-918
Which versions are affected by CVE-2025-64430?
5 open source packages ship an affected version, including parse-server and parse.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | From 4.2.0 | 7.5.4 |
parse-server npm | From 4.2.0 | 7.5.4 |
parse-server npm | From 8.0.0 | 8.4.0-alpha.2 |
parse-server npm | From 8.0.0 | 8.4.0-alpha.2 |
parse Bitnami | From 4.2.0 | 7.5.4, 8.4.0 |
How do I fix CVE-2025-64430?
Upgrade parse-server to a fixed version for your release line: 7.5.4 or 8.4.0-alpha.2.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2025-64430 being exploited?
There is no known exploitation of CVE-2025-64430 in the wild and no public exploit code.
Sources
Also known as BIT-parse-2025-64430, GHSA-x4qj-2f4q-r4rx.