{"answers":{"affected":"5 open source packages ship an affected version, including parse-server and parse.","exploited":"There is no known exploitation of CVE-2025-64430 in the wild and no public exploit code.","fix":"Upgrade parse-server to a fixed version for your release line: 7.5.4 or 8.4.0-alpha.2.","what":"CVE-2025-64430 is a high-severity server-side request forgery vulnerability in parse-community parse-server, published on 7 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-64430 and fix it if it is affected.\n\nWhat it is: CVE-2025-64430 is a high-severity server-side request forgery vulnerability in parse-community parse-server, published on 7 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-64430 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- parse-server (npm): affected from 4.2.0; fixed in 7.5.4\n- parse-server (npm): affected from 4.2.0; fixed in 7.5.4\n- parse-server (npm): affected from 8.0.0; fixed in 8.4.0-alpha.2\n- parse-server (npm): affected from 8.0.0; fixed in 8.4.0-alpha.2\n- parse (Bitnami): affected from 4.2.0; fixed in 7.5.4, 8.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64430/ (Markdown: https://insights.sbomify.com/CVE-2025-64430/index.md)","id":"CVE-2025-64430","markdown":"https://insights.sbomify.com/CVE-2025-64430/index.md","name":"CVE-2025-64430","record":{"aliases":["BIT-parse-2025-64430","GHSA-x4qj-2f4q-r4rx"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Parse Server backend","requires_auth":"none","summary":"Attackers can trigger Server-Side Request Forgery via file upload URIs, potentially reading internal data or causing server crashes.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions 4.2.0 through 7.5.3, and 8.0.0 through 8.3.1-alpha.1, there is a Server-Side Request Forgery (SSRF) vulnerability in the file upload functionality when trying to upload a Parse.File with uri parameter, allowing execution of an arbitrary URI. The vulnerability stems from a file upload feature in which Parse Server retrieves the file data from a URI that is provided in the request. A request to the provided URI is executed, but the response is not stored in Parse Server's file storage as the server crashes upon receiving the response. This issue is fixed in versions 7.5.4 and 8.4.0-alpha.1.","ecosystems":["Bitnami","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Parse Server Vulnerable to Server-Side Request Forgery (SSRF) in File Upload via URI Format","id":"CVE-2025-64430","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"ssrf","year":"2025"},"n_packages":5,"n_references":5,"next":{"headline":"IDOR Vulnerabilities in ZITADEL's Organization API allows Cross-Tenant Data Tempering","id":"CVE-2025-64431"},"packages":[{"ecosystem":"Bitnami","fixed":["7.5.4","8.4.0"],"introduced":["4.2.0","8.0.0"],"last_affected":[],"package":"parse","purl":"pkg:bitnami/parse","source":"BIT-parse-2025-64430"},{"ecosystem":"npm","fixed":["7.5.4"],"introduced":["4.2.0"],"last_affected":[],"package":"parse-server","purl":null,"source":"GHSA-x4qj-2f4q-r4rx"},{"ecosystem":"npm","fixed":["7.5.4"],"introduced":["4.2.0"],"last_affected":[],"package":"parse-server","purl":"pkg:npm/parse-server","source":"GHSA-x4qj-2f4q-r4rx"},{"ecosystem":"npm","fixed":["8.4.0-alpha.2"],"introduced":["8.0.0"],"last_affected":[],"package":"parse-server","purl":null,"source":"GHSA-x4qj-2f4q-r4rx"},{"ecosystem":"npm","fixed":["8.4.0-alpha.2"],"introduced":["8.0.0"],"last_affected":[],"package":"parse-server","purl":"pkg:npm/parse-server","source":"GHSA-x4qj-2f4q-r4rx"}],"prev":{"headline":"DuckDB Encryption Crypto implementation is vulnerable","id":"CVE-2025-64429"},"products":["parse-server"],"published":"2025-11-07","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-07","vendors":["parse-community"]},"summary":"Attackers can trigger Server-Side Request Forgery via file upload URIs, potentially reading internal data or causing server crashes.","url":"https://insights.sbomify.com/CVE-2025-64430/"}