# CVE-2025-64430: Parse Server Vulnerable to Server-Side Request Forgery (SSRF) in File Upload via URI Format

> Attackers can trigger Server-Side Request Forgery via file upload URIs, potentially reading internal data or causing server crashes.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Nov 2025
- **Updated:** 7 Nov 2025
- **Also known as:** BIT-parse-2025-64430, GHSA-x4qj-2f4q-r4rx

## What is CVE-2025-64430?

CVE-2025-64430 is a high-severity server-side request forgery vulnerability in parse-community parse-server, published on 7 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions 4.2.0 through 7.5.3, and 8.0.0 through 8.3.1-alpha.1, there is a Server-Side Request Forgery (SSRF) vulnerability in the file upload functionality when trying to upload a Parse.File with uri parameter, allowing execution of an arbitrary URI. The vulnerability stems from a file upload feature in which Parse Server retrieves the file data from a URI that is provided in the request. A request to the provided URI is executed, but the response is not stored in Parse Server's file storage as the server crashes upon receiving the response. This issue is fixed in versions 7.5.4 and 8.4.0-alpha.1.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-64430?

5 open source packages ship an affected version, including parse-server and parse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | From 4.2.0 | 7.5.4 |
| `parse-server` | npm | From 4.2.0 | 7.5.4 |
| `parse-server` | npm | From 8.0.0 | 8.4.0-alpha.2 |
| `parse-server` | npm | From 8.0.0 | 8.4.0-alpha.2 |
| `parse` | Bitnami | From 4.2.0 | 7.5.4, 8.4.0 |

## How do I fix CVE-2025-64430?

Upgrade parse-server to a fixed version for your release line: 7.5.4 or 8.4.0-alpha.2.

## Is CVE-2025-64430 being exploited?

There is no known exploitation of CVE-2025-64430 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64430 and fix it if it is affected.

What it is: CVE-2025-64430 is a high-severity server-side request forgery vulnerability in parse-community parse-server, published on 7 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64430 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected from 4.2.0; fixed in 7.5.4
- parse-server (npm): affected from 4.2.0; fixed in 7.5.4
- parse-server (npm): affected from 8.0.0; fixed in 8.4.0-alpha.2
- parse-server (npm): affected from 8.0.0; fixed in 8.4.0-alpha.2
- parse (Bitnami): affected from 4.2.0; fixed in 7.5.4, 8.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64430/ (Markdown: https://insights.sbomify.com/CVE-2025-64430/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64430
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64430
- OSV: https://osv.dev/vulnerability/CVE-2025-64430

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64430/
Summaries are generated and may contain mistakes; the official description above is the record.
