CVE-2025-64431 IDOR Vulnerabilities in ZITADEL's Organization API allows Cross-Tenant Data Tempering
Authenticated administrators can modify organization data across tenants due to missing authorization checks in the API.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-64431?
CVE-2025-64431 is a high-severity missing authorization vulnerability in zitadel, published on 7 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Zitadel is an open source identity management platform. Versions 4.0.0-rc.1 through 4.6.2 are vulnerable to secure Direct Object Reference (IDOR) attacks through its V2Beta API, allowing authenticated users with specific administrator roles within one organization to access and modify data belonging to other organizations. Note that this vulnerability is limited to organization-level data (name, domains, metadata). No other related data (such as users, projects, applications, etc.) is affected. This issue is fixed in version 4.6.3.
Weakness: CWE-639
Which versions are affected by CVE-2025-64431?
5 open source packages ship an affected version, including github.com/zitadel/zitadel.
| Package | Affected | Fixed in |
|---|---|---|
github.com/zitadel/zitadel Go | From 1.80.0-v2.20.0.20250414095945-f365cee73242 | 1.80.0-v2.20.0.20251105083648-8dcfff97ed52 |
github.com/zitadel/zitadel Go | From 1.80.0-v2.20.0.20250414095945-f365cee73242 | 1.80.0-v2.20.0.20251105083648-8dcfff97ed52 |
github.com/zitadel/zitadel Go | From 1.80.0-v2.20.0.20250414095945-f365cee73242 | 1.80.0-v2.20.0.20251105083648-8dcfff97ed52 |
github.com/zitadel/zitadel Go | From 4.0.0-rc.1 | 4.6.3 |
github.com/zitadel/zitadel Go | From 4.0.0-rc.1 | 4.6.3 |
How do I fix CVE-2025-64431?
Upgrade github.com/zitadel/zitadel to a fixed version for your release line: 1.80.0-v2.20.0.20251105083648-8dcfff97ed52 or 4.6.3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-64431 being exploited?
There is no known exploitation of CVE-2025-64431 in the wild and no public exploit code.
Sources
Also known as GHSA-cpf4-pmr4-w6cx, GO-2025-4099.