# CVE-2025-64433: KubeVirt Arbitrary Container File Read

> A malicious user with PVC control can read arbitrary files from the virt-launcher pod via symlink abuse, bypassing UID restrictions.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Nov 2025
- **Updated:** 10 Nov 2025
- **Also known as:** AZL-69799, AZL-69958, GHSA-qw6q-3pgr-5cwq, GO-2025-4109, MINI-fgj7-85wg-q85x, MINI-mhm4-2fgw-g69r

## What is CVE-2025-64433?

CVE-2025-64433 is a medium-severity path traversal vulnerability in kubevirt, published on 7 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

KubeVirt is a virtual machine management add-on for Kubernetes. Prior to 1.5.3 and 1.6.1, a vulnerability was discovered that allows a VM to read arbitrary files from the virt-launcher pod's file system. This issue stems from improper symlink handling when mounting PVC disks into a VM. Specifically, if a malicious user has full or partial control over the contents of a PVC, they can create a symbolic link that points to a file within the virt-launcher pod's file system. Since libvirt can treat regular files as block devices, any file on the pod's file system that is symlinked in this way can be mounted into the VM and subsequently read. Although a security mechanism exists where VMs are executed as an unprivileged user with UID 107 inside the virt-launcher container, limiting the scope of accessible resources, this restriction is bypassed due to a second vulnerability. The latter causes the ownership of any file intended for mounting to be changed to the unprivileged user with UID 107 prior to mounting. As a result, an attacker can gain access to and read arbitrary files located within the virt-launcher pod's file system or on a mounted PVC from within the guest VM. This vulnerability is fixed in 1.5.3 and 1.6.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-64433?

5 open source packages ship an affected version, including kubevirt.io/kubevirt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kubevirt.io/kubevirt` | Go | All versions | 1.5.3, 1.6.0-beta.0.0.20250801195231-a81b27d4600c, 1.6.1 |
| `kubevirt.io/kubevirt` | Go | All versions | 1.5.3 |
| `kubevirt.io/kubevirt` | Go | All versions | 1.5.3 |
| `kubevirt.io/kubevirt` | Go | From 1.6.0-alpha.0 | 1.6.1 |
| `kubevirt.io/kubevirt` | Go | From 1.6.0-alpha.0 | 1.6.1 |

Products: Kubevirt Kubevirt.

## How do I fix CVE-2025-64433?

Upgrade kubevirt.io/kubevirt to a fixed version for your release line: 1.5.3, 1.6.0-beta.0.0.20250801195231-a81b27d4600c or 1.6.1.

## Is CVE-2025-64433 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64433 exists.

## Other vulnerabilities in kubevirt

- [CVE-2020-14316](https://insights.sbomify.com/CVE-2020-14316/): Privilege Escalation in kubevirt (critical 9.9)
- [CVE-2022-1798](https://insights.sbomify.com/CVE-2022-1798/): Path Traversal vulnerability in Kubevirt (high 8.7)
- [CVE-2025-64324](https://insights.sbomify.com/CVE-2025-64324/): KubeVirt Vulnerable to Arbitrary Host File Read and Write (high 8.5)
- [CVE-2023-26484](https://insights.sbomify.com/CVE-2023-26484/): On a compromised KubeVirt node, the virt-handler service account can be used to modify all node specs (high 8.2)
- [CVE-2026-13201](https://insights.sbomify.com/CVE-2026-13201/): Path traversal in Red Hat Container Native Virtualization 4.12 (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64433 and fix it if it is affected.

What it is: CVE-2025-64433 is a medium-severity path traversal vulnerability in kubevirt, published on 7 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64433 exists.

Affected packages and fixed versions:
- kubevirt.io/kubevirt (Go): affected all versions; fixed in 1.5.3, 1.6.0-beta.0.0.20250801195231-a81b27d4600c, 1.6.1
- kubevirt.io/kubevirt (Go): affected all versions; fixed in 1.5.3
- kubevirt.io/kubevirt (Go): affected all versions; fixed in 1.5.3
- kubevirt.io/kubevirt (Go): affected from 1.6.0-alpha.0; fixed in 1.6.1
- kubevirt.io/kubevirt (Go): affected from 1.6.0-alpha.0; fixed in 1.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64433/ (Markdown: https://insights.sbomify.com/CVE-2025-64433/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64433
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64433
- OSV: https://osv.dev/vulnerability/CVE-2025-64433

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64433/
Summaries are generated and may contain mistakes; the official description above is the record.
