# CVE-2025-64435: KubeVirt VMI Denial-of-Service (DoS) Using Pod Impersonation

> An attacker can cause denial of service in KubeVirt by impersonating a virt-launcher pod, misleading the controller into incorrect status updates.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Nov 2025
- **Updated:** 10 Nov 2025
- **Also known as:** AZL-69802, AZL-69964, GHSA-9m94-w2vq-hcf9, GO-2025-4105, MINI-g76c-6fqv-232h, MINI-q5w5-gxg8-3p46, MINI-v9r3-hch9-vvxm, MINI-vr6p-8h84-3xwf

## What is CVE-2025-64435?

CVE-2025-64435 is a medium-severity vulnerability in kubevirt, published on 7 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

KubeVirt is a virtual machine management add-on for Kubernetes. Prior to 1.7.0-beta.0, a logic flaw in the virt-controller allows an attacker to disrupt the control over a running VMI by creating a pod with the same labels as the legitimate virt-launcher pod associated with the VMI. This can mislead the virt-controller into associating the fake pod with the VMI, resulting in incorrect status updates and potentially causing a DoS (Denial-of-Service). This vulnerability is fixed in 1.7.0-beta.0.

Weakness: CWE-703 (Improper Check or Handling of Exceptional Conditions)

## Which versions are affected by CVE-2025-64435?

3 open source packages ship an affected version, including kubevirt.io/kubevirt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kubevirt.io/kubevirt` | Go | All versions | 1.7.0-beta.0 |
| `kubevirt.io/kubevirt` | Go | All versions | 1.7.0-beta.0 |
| `kubevirt.io/kubevirt` | Go | All versions | 1.7.0-beta.0 |

Products: Kubevirt Kubevirt.

## How do I fix CVE-2025-64435?

Upgrade kubevirt.io/kubevirt to 1.7.0-beta.0 or later.

## Is CVE-2025-64435 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64435 exists.

## Other vulnerabilities in kubevirt

- [CVE-2020-14316](https://insights.sbomify.com/CVE-2020-14316/): Privilege Escalation in kubevirt (critical 9.9)
- [CVE-2022-1798](https://insights.sbomify.com/CVE-2022-1798/): Path Traversal vulnerability in Kubevirt (high 8.7)
- [CVE-2025-64324](https://insights.sbomify.com/CVE-2025-64324/): KubeVirt Vulnerable to Arbitrary Host File Read and Write (high 8.5)
- [CVE-2023-26484](https://insights.sbomify.com/CVE-2023-26484/): On a compromised KubeVirt node, the virt-handler service account can be used to modify all node specs (high 8.2)
- [CVE-2026-13201](https://insights.sbomify.com/CVE-2026-13201/): Path traversal in Red Hat Container Native Virtualization 4.12 (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64435 and fix it if it is affected.

What it is: CVE-2025-64435 is a medium-severity vulnerability in kubevirt, published on 7 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64435 exists.

Affected packages and fixed versions:
- kubevirt.io/kubevirt (Go): affected all versions; fixed in 1.7.0-beta.0
- kubevirt.io/kubevirt (Go): affected all versions; fixed in 1.7.0-beta.0
- kubevirt.io/kubevirt (Go): affected all versions; fixed in 1.7.0-beta.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64435/ (Markdown: https://insights.sbomify.com/CVE-2025-64435/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64435
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64435
- OSV: https://osv.dev/vulnerability/CVE-2025-64435

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64435/
Summaries are generated and may contain mistakes; the official description above is the record.
