# CVE-2025-64436: KubeVirt Excessive Role Permissions Could Enable Unauthorized VMI Migrations Between Nodes

> Excessive permissions in KubeVirt allow attackers to force VM migrations to compromised nodes, enabling privilege escalation and potential code execution.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Nov 2025
- **Updated:** 10 Nov 2025
- **Also known as:** AZL-69790, AZL-69967, GHSA-7xgm-5prm-v5gc, GO-2025-4104, MINI-76cc-9xwj-6hf9, MINI-g6f2-qjjw-4vxg, MINI-wf83-fpwc-8fhm, MINI-wj86-c5px-5hgp

## What is CVE-2025-64436?

CVE-2025-64436 is a medium-severity vulnerability in kubevirt, published on 7 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

KubeVirt is a virtual machine management add-on for Kubernetes. In 1.5.0 and earlier, the permissions granted to the virt-handler service account, such as the ability to update VMI and patch nodes, could be abused to force a VMI migration to an attacker-controlled node. This vulnerability could otherwise allow an attacker to mark all nodes as unschedulable, potentially forcing the migration or creation of privileged pods onto a compromised node.

Weakness: CWE-276 (Incorrect Default Permissions), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2025-64436?

3 open source packages ship an affected version, including kubevirt.io/kubevirt and github.com/kubevirt/kubevirt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kubevirt.io/kubevirt` | Go | All versions | 1.7.0 |
| `kubevirt.io/kubevirt` | Go | All versions | 1.7.0 |
| `github.com/kubevirt/kubevirt` | Go | All versions | None |

Products: Kubevirt Kubevirt.

## How do I fix CVE-2025-64436?

Upgrade kubevirt.io/kubevirt to 1.7.0 or later.

## Is CVE-2025-64436 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64436 exists.

## Other vulnerabilities in kubevirt

- [CVE-2020-14316](https://insights.sbomify.com/CVE-2020-14316/): Privilege Escalation in kubevirt (critical 9.9)
- [CVE-2022-1798](https://insights.sbomify.com/CVE-2022-1798/): Path Traversal vulnerability in Kubevirt (high 8.7)
- [CVE-2025-64324](https://insights.sbomify.com/CVE-2025-64324/): KubeVirt Vulnerable to Arbitrary Host File Read and Write (high 8.5)
- [CVE-2023-26484](https://insights.sbomify.com/CVE-2023-26484/): On a compromised KubeVirt node, the virt-handler service account can be used to modify all node specs (high 8.2)
- [CVE-2026-13201](https://insights.sbomify.com/CVE-2026-13201/): Path traversal in Red Hat Container Native Virtualization 4.12 (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64436 and fix it if it is affected.

What it is: CVE-2025-64436 is a medium-severity vulnerability in kubevirt, published on 7 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64436 exists.

Affected packages and fixed versions:
- kubevirt.io/kubevirt (Go): affected all versions; fixed in 1.7.0
- kubevirt.io/kubevirt (Go): affected all versions; fixed in 1.7.0
- github.com/kubevirt/kubevirt (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64436/ (Markdown: https://insights.sbomify.com/CVE-2025-64436/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64436
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64436
- OSV: https://osv.dev/vulnerability/CVE-2025-64436

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64436/
Summaries are generated and may contain mistakes; the official description above is the record.
