# CVE-2025-64437: KubeVirt Isolation Detection Flaw Allows Arbitrary File Permission Changes

> Attackers controlling the virt-launcher pod filesystem can change ownership of arbitrary host files via symlink exploitation, compromising host data integrity.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Nov 2025
- **Updated:** 10 Nov 2025
- **Also known as:** AZL-69805, AZL-69970, GHSA-2r4r-5x78-mvqf, GO-2025-4102, MINI-6wqx-5pj7-6hg8, MINI-hvp4-48v9-6fc5

## What is CVE-2025-64437?

CVE-2025-64437 is a medium-severity path traversal vulnerability in kubevirt, published on 7 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

KubeVirt is a virtual machine management add-on for Kubernetes. In versions before 1.5.3 and 1.6.1, the virt-handler does not verify whether the launcher-sock is a symlink or a regular file. This oversight can be exploited, for example, to change the ownership of arbitrary files on the host node to the unprivileged user with UID 107 (the same user used by virt-launcher) thus, compromising the CIA (Confidentiality, Integrity and Availability) of data on the host. To successfully exploit this vulnerability, an attacker should be in control of the file system of the virt-launcher pod. This vulnerability is fixed in 1.5.3 and 1.6.1.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2025-64437?

5 open source packages ship an affected version, including kubevirt.io/kubevirt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kubevirt.io/kubevirt` | Go | All versions | 1.5.3, 1.6.0-beta.0.0.20250801202148-3ce9f41c54d0 |
| `kubevirt.io/kubevirt` | Go | All versions | 1.5.3 |
| `kubevirt.io/kubevirt` | Go | All versions | 1.5.3 |
| `kubevirt.io/kubevirt` | Go | From 1.6.0-alpha.0 | 1.6.1 |
| `kubevirt.io/kubevirt` | Go | From 1.6.0-alpha.0 | 1.6.1 |

Products: Kubevirt Kubevirt.

## How do I fix CVE-2025-64437?

Upgrade kubevirt.io/kubevirt to a fixed version for your release line: 1.5.3, 1.6.0-beta.0.0.20250801202148-3ce9f41c54d0 or 1.6.1.

## Is CVE-2025-64437 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64437 exists.

## Other vulnerabilities in kubevirt

- [CVE-2020-14316](https://insights.sbomify.com/CVE-2020-14316/): Privilege Escalation in kubevirt (critical 9.9)
- [CVE-2022-1798](https://insights.sbomify.com/CVE-2022-1798/): Path Traversal vulnerability in Kubevirt (high 8.7)
- [CVE-2025-64324](https://insights.sbomify.com/CVE-2025-64324/): KubeVirt Vulnerable to Arbitrary Host File Read and Write (high 8.5)
- [CVE-2023-26484](https://insights.sbomify.com/CVE-2023-26484/): On a compromised KubeVirt node, the virt-handler service account can be used to modify all node specs (high 8.2)
- [CVE-2026-13201](https://insights.sbomify.com/CVE-2026-13201/): Path traversal in Red Hat Container Native Virtualization 4.12 (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64437 and fix it if it is affected.

What it is: CVE-2025-64437 is a medium-severity path traversal vulnerability in kubevirt, published on 7 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64437 exists.

Affected packages and fixed versions:
- kubevirt.io/kubevirt (Go): affected all versions; fixed in 1.5.3, 1.6.0-beta.0.0.20250801202148-3ce9f41c54d0
- kubevirt.io/kubevirt (Go): affected all versions; fixed in 1.5.3
- kubevirt.io/kubevirt (Go): affected all versions; fixed in 1.5.3
- kubevirt.io/kubevirt (Go): affected from 1.6.0-alpha.0; fixed in 1.6.1
- kubevirt.io/kubevirt (Go): affected from 1.6.0-alpha.0; fixed in 1.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64437/ (Markdown: https://insights.sbomify.com/CVE-2025-64437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64437
- OSV: https://osv.dev/vulnerability/CVE-2025-64437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64437/
Summaries are generated and may contain mistakes; the official description above is the record.
