{"answers":{"affected":"3 open source packages ship an affected version, including langgraph-checkpoint.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64439 exists.","fix":"Upgrade langgraph-checkpoint to 3.0.0 or later.","what":"CVE-2025-64439 is a high-severity unsafe deserialization vulnerability in langchain-ai langgraph, published on 7 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-64439 and fix it if it is affected.\n\nWhat it is: CVE-2025-64439 is a high-severity unsafe deserialization vulnerability in langchain-ai langgraph, published on 7 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64439 exists.\n\nAffected packages and fixed versions:\n- langgraph-checkpoint (PyPI): affected all versions; fixed in 3.0.0\n- langgraph-checkpoint (PyPI): affected all versions; fixed in 3.0.0\n- langgraph-checkpoint (PyPI): affected all versions; fixed in 3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64439/ (Markdown: https://insights.sbomify.com/CVE-2025-64439/index.md)","id":"CVE-2025-64439","markdown":"https://insights.sbomify.com/CVE-2025-64439/index.md","name":"CVE-2025-64439","record":{"aliases":["CLSA-2026-1779670109","GHSA-wwqv-p2pp-99h5","PYSEC-2026-1527","ROOT-APP-PYPI-CVE-2025-64439"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"LangGraph checkpoint library","requires_auth":"low_privilege","summary":"Attackers can achieve remote code execution by exploiting unsafe deserialization in the JsonPlusSerializer when the system falls back to JSON mode.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"LangGraph SQLite Checkpoint is an implementation of LangGraph CheckpointSaver that uses SQLite DB (both sync and async, via aiosqlite). In versions 2.1.2 and below, the JsonPlusSerializer (used as the default serialization protocol for all checkpointing) contains a Remote Code Execution (RCE) vulnerability when deserializing payloads saved in the \"json\" serialization mode. By default, the serializer attempts to use \"msgpack\" for serialization. However, prior to version 3.0 of the checkpointer library, if illegal Unicode surrogate values caused serialization to fail, it would fall back to using the \"json\" mode. This issue is fixed in version 3.0.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"LangGraph Checkpoint affected by RCE in \"json\" mode of JsonPlusSerializer","id":"CVE-2025-64439","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":3,"n_references":4,"next":{"headline":"HumHub is vulnerable to XSS through its Meta Search component","id":"CVE-2025-64442"},"packages":[{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"langgraph-checkpoint","purl":null,"source":"GHSA-wwqv-p2pp-99h5"},{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"langgraph-checkpoint","purl":"pkg:pypi/langgraph-checkpoint","source":"GHSA-wwqv-p2pp-99h5"},{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"langgraph-checkpoint","purl":"pkg:pypi/langgraph-checkpoint","source":"PYSEC-2026-1527"}],"prev":{"headline":"Fast-DDS: Unbounded GAP range triggers OOM DoS under RELIABLE QoS","id":"CVE-2025-64438"},"products":["langgraph"],"published":"2025-11-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-07","vendors":["langchain-ai"]},"summary":"Attackers can achieve remote code execution by exploiting unsafe deserialization in the JsonPlusSerializer when the system falls back to JSON mode.","url":"https://insights.sbomify.com/CVE-2025-64439/"}