CVE-2025-64458 Potential denial-of-service vulnerability in HttpResponseRedirect and HttpResponsePermanentRedirect on Windows
Attackers can cause denial of service in Django on Windows by sending redirect responses with excessive Unicode characters, requiring an upgrade.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-64458?
CVE-2025-64458 is a high-severity denial of service vulnerability in Djangoproject Django, published on 5 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in 5.1 before 5.1.14, 4.2 before 4.2.26, and 5.2 before 5.2.8. NFKC normalization in Python is slow on Windows. As a consequence, `django.http.HttpResponseRedirect`, `django.http.HttpResponsePermanentRedirect`, and the shortcut `django.shortcuts.redirect` were subject to a potential denial-of-service attack via certain inputs with a very large number of Unicode characters. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank Seokchan Yoon for reporting this issue.
Weakness: CWE-407
Which versions are affected by CVE-2025-64458?
8 open source packages ship an affected version, including django. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
django Bitnami | From 4.2.0 | 4.2.26, 5.1.14, 5.2.8 |
django PyPI | All versions | 4.2.26 |
django PyPI | All versions | 4.2.26 |
django PyPI | From 4.2 | 4.2.26, 5.1.14, 5.2.8 |
django PyPI | From 5.0a1 | 5.1.14 |
django PyPI | From 5.0a1 | 5.1.14 |
2 more packages
django PyPI | From 5.2a1 | 5.2.8 |
django PyPI | From 5.2a1 | 5.2.8 |
Products include Djangoproject Django.
How do I fix CVE-2025-64458?
Upgrade django to a fixed version for your release line: 4.2.26, 5.1.14 or 5.2.8.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-64458 being exploited?
There is no known exploitation of CVE-2025-64458 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Djangoproject Django
- CVE-2026-4277 Privilege abuse in GenericInlineModelAdmin
- CVE-2024-53908 Django SQL injection in HasKey(lhs, rhs) on Oracle
- CVE-2024-42005 Django SQL injection vulnerability
- CVE-2023-31047 Django bypasses validation when using one form field to upload multiple files
- CVE-2022-34265 Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection
Sources
Also known as BIT-django-2025-64458, CLSA-2026-1787552198, ECHO-879a-fe35-cf61, GHSA-qw25-v68c-qjf3, PYSEC-2025-107, ROOT-APP-PYPI-CVE-2025-64458.