# CVE-2025-64458: Potential denial-of-service vulnerability in HttpResponseRedirect and HttpResponsePermanentRedirect on Windows

> Attackers can cause denial of service in Django on Windows by sending redirect responses with excessive Unicode characters, requiring an upgrade.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Nov 2025
- **Updated:** 5 Nov 2025
- **Also known as:** BIT-django-2025-64458, CLSA-2026-1787552198, ECHO-879a-fe35-cf61, GHSA-qw25-v68c-qjf3, PYSEC-2025-107, ROOT-APP-PYPI-CVE-2025-64458

## What is CVE-2025-64458?

CVE-2025-64458 is a high-severity denial of service vulnerability in Djangoproject Django, published on 5 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in 5.1 before 5.1.14, 4.2 before 4.2.26, and 5.2 before 5.2.8.
NFKC normalization in Python is slow on Windows. As a consequence, `django.http.HttpResponseRedirect`, `django.http.HttpResponsePermanentRedirect`, and the shortcut `django.shortcuts.redirect`  were subject to a potential  denial-of-service attack via certain inputs with a very large number of Unicode characters.
Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected.
Django would like to thank Seokchan Yoon for reporting this issue.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2025-64458?

8 open source packages ship an affected version, including django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 4.2.0 | 4.2.26, 5.1.14, 5.2.8 |
| `django` | PyPI | All versions | 4.2.26 |
| `django` | PyPI | All versions | 4.2.26 |
| `django` | PyPI | From 4.2 | 4.2.26, 5.1.14, 5.2.8 |
| `django` | PyPI | From 5.0a1 | 5.1.14 |
| `django` | PyPI | From 5.0a1 | 5.1.14 |
| `django` | PyPI | From 5.2a1 | 5.2.8 |
| `django` | PyPI | From 5.2a1 | 5.2.8 |

Products: Djangoproject Django.

## How do I fix CVE-2025-64458?

Upgrade django to a fixed version for your release line: 4.2.26, 5.1.14 or 5.2.8.

## Is CVE-2025-64458 being exploited?

There is no known exploitation of CVE-2025-64458 in the wild and no public exploit code.

Public exploit code:

- A PoC script for demonstrating CVE 2025-64458, found in Django, potential DoS in `HttpResponseRedirect`/`HttpResponsePermanentRedirect` on Windows. (github_poc): https://github.com/ch4n3-yoon/CVE-2025-64458-Demo

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64458 and fix it if it is affected.

What it is: CVE-2025-64458 is a high-severity denial of service vulnerability in Djangoproject Django, published on 5 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64458 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 4.2.0; fixed in 4.2.26, 5.1.14, 5.2.8
- django (PyPI): affected all versions; fixed in 4.2.26
- django (PyPI): affected all versions; fixed in 4.2.26
- django (PyPI): affected from 4.2; fixed in 4.2.26, 5.1.14, 5.2.8
- django (PyPI): affected from 5.0a1; fixed in 5.1.14
- django (PyPI): affected from 5.0a1; fixed in 5.1.14
- django (PyPI): affected from 5.2a1; fixed in 5.2.8
- django (PyPI): affected from 5.2a1; fixed in 5.2.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64458/ (Markdown: https://insights.sbomify.com/CVE-2025-64458/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64458
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64458
- OSV: https://osv.dev/vulnerability/CVE-2025-64458

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64458/
Summaries are generated and may contain mistakes; the official description above is the record.
