CVE-2025-64459 Potential SQL injection via _connector keyword argument in QuerySet and Q objects
Attackers can execute arbitrary SQL commands via crafted dictionary arguments in Django QuerySet and Q objects, potentially reading or modifying database contents.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-64459?
CVE-2025-64459 is a critical SQL injection vulnerability in Djangoproject Django, published on 5 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in 5.1 before 5.1.14, 4.2 before 4.2.26, and 5.2 before 5.2.8. The methods `QuerySet.filter()`, `QuerySet.exclude()`, and `QuerySet.get()`, and the class `Q()`, are subject to SQL injection when using a suitably crafted dictionary, with dictionary expansion, as the `_connector` argument. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank cyberstan for reporting this issue.
Weakness: CWE-89
Which versions are affected by CVE-2025-64459?
8 open source packages ship an affected version, including django. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
django Bitnami | From 4.2.0 | 4.2.26, 5.1.14, 5.2.8 |
django PyPI | All versions | 4.2.26 |
django PyPI | All versions | 4.2.26 |
django PyPI | From 4.2 | 4.2.26, 5.1.14, 5.2.8 |
django PyPI | From 5.0a1 | 5.1.14 |
django PyPI | From 5.0a1 | 5.1.14 |
2 more packages
django PyPI | From 5.2a1 | 5.2.8 |
django PyPI | From 5.2a1 | 5.2.8 |
Linux distribution packages (5)
automation-controller-venv-tower Red Hat:ansible_automation_platform:2.6::el9 | All versions | 0:4.7.6-1.el9ap |
python3.11-django Red Hat:ansible_automation_platform:2.6::el9 | All versions | 0:4.2.26-2.el9ap |
python3.11-django Red Hat:ansible_automation_platform_developer:2.6::el9 | All versions | 0:4.2.26-2.el9ap |
python-Django openSUSE:Tumbleweed | All versions | 5.2.8-1.1 |
python-Django4 openSUSE:Tumbleweed | All versions | 4.2.26-1.1 |
Products include Djangoproject Django.
How do I fix CVE-2025-64459?
Upgrade django to a fixed version for your release line: 4.2.26, 5.1.14 or 5.2.8.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2025-64459 being exploited?
There is no known exploitation of CVE-2025-64459 in the wild and no public exploit code.
Public exploit code: 1 Exploit-DB entry and 10 proofs of concept on GitHub.
Other vulnerabilities in Djangoproject Django
- CVE-2026-4277 Privilege abuse in GenericInlineModelAdmin
- CVE-2024-53908 Django SQL injection in HasKey(lhs, rhs) on Oracle
- CVE-2024-42005 Django SQL injection vulnerability
- CVE-2023-31047 Django bypasses validation when using one form field to upload multiple files
- CVE-2022-34265 Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection
Sources
Also known as BIT-django-2025-64459, CLSA-2026-1786600198, CLSA-2026-1786604588, CLSA-2026-1786616091, CLSA-2026-1786616142, CLSA-2026-1786616143 and 14 more.