# CVE-2025-64459: Potential SQL injection via _connector keyword argument in QuerySet and Q objects

> Attackers can execute arbitrary SQL commands via crafted dictionary arguments in Django QuerySet and Q objects, potentially reading or modifying database contents.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Nov 2025
- **Updated:** 26 Feb 2026
- **Also known as:** BIT-django-2025-64459, CLSA-2026-1786600198, CLSA-2026-1786604588, CLSA-2026-1786616091, CLSA-2026-1786616142, CLSA-2026-1786616143, CLSA-2026-1787718155, DEBIAN-CVE-2025-64459, ECHO-1dc5-af13-00c1, GHSA-frmv-pr5f-9mcr, MGASA-2025-0292, MINI-w5w4-2wvv-vrf5, OESA-2026-1206, PYSEC-2025-108, RHSA-2025:23070, ROOT-APP-PYPI-CVE-2025-64459, UBUNTU-CVE-2025-64459, USN-7859-1, openSUSE-SU-2025:15708-1, openSUSE-SU-2025:15712-1

## What is CVE-2025-64459?

CVE-2025-64459 is a critical SQL injection vulnerability in Djangoproject Django, published on 5 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in 5.1 before 5.1.14, 4.2 before 4.2.26, and 5.2 before 5.2.8.
The methods `QuerySet.filter()`, `QuerySet.exclude()`, and `QuerySet.get()`, and the class `Q()`, are subject to SQL injection when using a suitably crafted dictionary, with dictionary expansion, as the `_connector` argument.
Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected.
Django would like to thank cyberstan for reporting this issue.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-64459?

8 open source packages ship an affected version, including django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 4.2.0 | 4.2.26, 5.1.14, 5.2.8 |
| `django` | PyPI | All versions | 4.2.26 |
| `django` | PyPI | All versions | 4.2.26 |
| `django` | PyPI | From 4.2 | 4.2.26, 5.1.14, 5.2.8 |
| `django` | PyPI | From 5.0a1 | 5.1.14 |
| `django` | PyPI | From 5.0a1 | 5.1.14 |
| `django` | PyPI | From 5.2a1 | 5.2.8 |
| `django` | PyPI | From 5.2a1 | 5.2.8 |
| `automation-controller-venv-tower` | Red Hat:ansible_automation_platform:2.6::el9 | All versions | 0:4.7.6-1.el9ap |
| `python3.11-django` | Red Hat:ansible_automation_platform:2.6::el9 | All versions | 0:4.2.26-2.el9ap |
| `python3.11-django` | Red Hat:ansible_automation_platform_developer:2.6::el9 | All versions | 0:4.2.26-2.el9ap |
| `python-Django` | openSUSE:Tumbleweed | All versions | 5.2.8-1.1 |
| `python-Django4` | openSUSE:Tumbleweed | All versions | 4.2.26-1.1 |

Products: Djangoproject Django.

## How do I fix CVE-2025-64459?

Upgrade django to a fixed version for your release line: 4.2.26, 5.1.14 or 5.2.8.

## Is CVE-2025-64459 being exploited?

There is no known exploitation of CVE-2025-64459 in the wild and no public exploit code.

Public exploit code:

- A self-contained testbed for Django CVE-2025-64459. Demonstrates QuerySet.filter() parameter injection via dictionary expansion using Docker. (github_poc): https://github.com/omarkurt/django-connector-CVE-2025-64459-testbed
- Vulnerability: SQL Injection via QuerySet and Q() keyword argument unpacking. CVE ID: CVE-2025-64459 Severity: Critical (CVSS 9.1) Affected Versions: Django 5.1 < 5.1.14, 4.2 < 4.2.26, and 5.2 < 5.2.8. Researcher: Cyberstan (University of Warwick) (github_poc): https://github.com/0xCyberstan/CVE-2025-64459-Poc
- check if vulnerable python-django version  to CVE-2025-64459 bug (github_poc): https://github.com/nunpa/CVE-2025-64459
- https://github.com/rockmelodies/django_sqli_target_CVE-2025-64459 (github_poc): https://github.com/rockmelodies/django_sqli_target_CVE-2025-64459
- Django 5.1.13 - SQL Injection (exploitdb)
- https://github.com/Z3YR0xX/CVE-2025-64459 (github_poc): https://github.com/Z3YR0xX/CVE-2025-64459

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64459 and fix it if it is affected.

What it is: CVE-2025-64459 is a critical SQL injection vulnerability in Djangoproject Django, published on 5 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64459 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 4.2.0; fixed in 4.2.26, 5.1.14, 5.2.8
- django (PyPI): affected all versions; fixed in 4.2.26
- django (PyPI): affected all versions; fixed in 4.2.26
- django (PyPI): affected from 4.2; fixed in 4.2.26, 5.1.14, 5.2.8
- django (PyPI): affected from 5.0a1; fixed in 5.1.14
- django (PyPI): affected from 5.0a1; fixed in 5.1.14
- django (PyPI): affected from 5.2a1; fixed in 5.2.8
- django (PyPI): affected from 5.2a1; fixed in 5.2.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64459/ (Markdown: https://insights.sbomify.com/CVE-2025-64459/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64459
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64459
- OSV: https://osv.dev/vulnerability/CVE-2025-64459

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64459/
Summaries are generated and may contain mistakes; the official description above is the record.
