CVE-2025-64460 Potential denial-of-service vulnerability in XML serializer text extraction
Remote attackers can cause denial of service via CPU and memory exhaustion in Django's XML serializer through specially crafted input.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-64460?
CVE-2025-64460 is a high-severity denial of service vulnerability in Djangoproject Django, published on 2 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in 5.2 before 5.2.9, 5.1 before 5.1.15, and 4.2 before 4.2.27. Algorithmic complexity in `django.core.serializers.xml_serializer.getInnerText()` allows a remote attacker to cause a potential denial-of-service attack triggering CPU and memory exhaustion via specially crafted XML input processed by the XML `Deserializer`. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank Seokchan Yoon for reporting this issue.
Weakness: CWE-407
Which versions are affected by CVE-2025-64460?
8 open source packages ship an affected version, including django and Django. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
django Bitnami | From 4.2.0 | 4.2.27, 5.1.15, 5.2.9 |
django PyPI | From 4.2 | 4.2.27, 5.1.15, 5.2.9 |
django PyPI | From 4.2a1 | 4.2.27 |
django PyPI | From 5.1a1 | 5.1.15 |
django PyPI | From 5.2a1 | 5.2.9 |
Django PyPI | From 4.2a1 | 4.2.27 |
2 more packages
Django PyPI | From 5.1a1 | 5.1.15 |
Django PyPI | From 5.2a1 | 5.2.9 |
Products include Djangoproject Django.
How do I fix CVE-2025-64460?
Upgrade django to a fixed version for your release line: 4.2.27, 5.1.15 or 5.2.9.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-64460 being exploited?
There is no known exploitation of CVE-2025-64460 in the wild and no public exploit code.
Other vulnerabilities in Djangoproject Django
- CVE-2026-4277 Privilege abuse in GenericInlineModelAdmin
- CVE-2024-53908 Django SQL injection in HasKey(lhs, rhs) on Oracle
- CVE-2024-42005 Django SQL injection vulnerability
- CVE-2023-31047 Django bypasses validation when using one form field to upload multiple files
- CVE-2022-34265 Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection
Sources
Also known as BIT-django-2025-64460, CLSA-2026-1787225546, DEBIAN-CVE-2025-64460, ECHO-b160-53db-8b4b, GHSA-vrcr-9hj9-jcg6, MINI-r6r3-3x7c-jjww and 6 more.