# CVE-2025-64460: Potential denial-of-service vulnerability in XML serializer text extraction

> Remote attackers can cause denial of service via CPU and memory exhaustion in Django's XML serializer through specially crafted input.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Dec 2025
- **Updated:** 2 Dec 2025
- **Also known as:** BIT-django-2025-64460, CLSA-2026-1787225546, DEBIAN-CVE-2025-64460, ECHO-b160-53db-8b4b, GHSA-vrcr-9hj9-jcg6, MINI-r6r3-3x7c-jjww, OESA-2025-2788, OESA-2025-2789, OESA-2025-2790, OESA-2026-1342, PYSEC-2025-109, UBUNTU-CVE-2025-64460

## What is CVE-2025-64460?

CVE-2025-64460 is a high-severity denial of service vulnerability in Djangoproject Django, published on 2 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in 5.2 before 5.2.9, 5.1 before 5.1.15, and 4.2 before 4.2.27.
Algorithmic complexity in `django.core.serializers.xml_serializer.getInnerText()` allows a remote attacker to cause a potential denial-of-service attack triggering CPU and memory exhaustion via specially crafted XML input processed by the XML `Deserializer`.
Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected.
Django would like to thank Seokchan Yoon for reporting this issue.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2025-64460?

8 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 4.2.0 | 4.2.27, 5.1.15, 5.2.9 |
| `django` | PyPI | From 4.2 | 4.2.27, 5.1.15, 5.2.9 |
| `django` | PyPI | From 4.2a1 | 4.2.27 |
| `django` | PyPI | From 5.1a1 | 5.1.15 |
| `django` | PyPI | From 5.2a1 | 5.2.9 |
| `Django` | PyPI | From 4.2a1 | 4.2.27 |
| `Django` | PyPI | From 5.1a1 | 5.1.15 |
| `Django` | PyPI | From 5.2a1 | 5.2.9 |

Products: Djangoproject Django.

## How do I fix CVE-2025-64460?

Upgrade django to a fixed version for your release line: 4.2.27, 5.1.15 or 5.2.9.

## Is CVE-2025-64460 being exploited?

There is no known exploitation of CVE-2025-64460 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64460 and fix it if it is affected.

What it is: CVE-2025-64460 is a high-severity denial of service vulnerability in Djangoproject Django, published on 2 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64460 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 4.2.0; fixed in 4.2.27, 5.1.15, 5.2.9
- django (PyPI): affected from 4.2; fixed in 4.2.27, 5.1.15, 5.2.9
- django (PyPI): affected from 4.2a1; fixed in 4.2.27
- django (PyPI): affected from 5.1a1; fixed in 5.1.15
- django (PyPI): affected from 5.2a1; fixed in 5.2.9
- Django (PyPI): affected from 4.2a1; fixed in 4.2.27
- Django (PyPI): affected from 5.1a1; fixed in 5.1.15
- Django (PyPI): affected from 5.2a1; fixed in 5.2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64460/ (Markdown: https://insights.sbomify.com/CVE-2025-64460/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64460
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64460
- OSV: https://osv.dev/vulnerability/CVE-2025-64460

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64460/
Summaries are generated and may contain mistakes; the official description above is the record.
